netbsd man page for cpu_idle

Query: cpu_idle

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CPU_IDLE(9)						   BSD Kernel Developer's Manual					       CPU_IDLE(9)

NAME
cpu_idle -- machine-dependent processor idling interface
SYNOPSIS
#include <sys/cpu.h> void cpu_idle(void);
DESCRIPTION
cpu_idle() is called by machine-independent code when the processor has nothing to do. It can be used to conserve the processor power, for example. cpu_idle() returns immediately if cpu_need_resched() has been called for the processor after the last call of cpu_idle() or cpu_did_resched() on the processor. cpu_idle() returns as soon as possible when cpu_need_resched() is called for the processor. Otherwise, it returns when- ever it likes. cpu_idle() is called at IPL_NONE, without any locks held.
EXAMPLES
The simplest (and, in some cases, the best) implementation of cpu_idle() is the following. void cpu_idle(void) { /* nothing */ }
SEE ALSO
cpu_need_resched(9), cpu_switchto(9), intro(9), spl(9)
BSD
April 20, 2007 BSD
Related Man Pages
pset_assign(2) - opensolaris
pset_create(2) - opensolaris
pset_info(1) - osf1
assign_cpu_to_pset(3) - osf1
processor_sets(4) - osf1
Similar Topics in the Unix Linux Community
vmstat displays cpu idle time at 100%
How to get the information about cpu idle from top command?
top is showing 0% cpu Idle
Help on shell script conditional execution when CPU Idle &gt; 60%
Why CPU idle 0 process nohub lose