netbsd man page for cpu_coredump

Query: cpu_coredump

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CPU_COREDUMP(9) 					   BSD Kernel Developer's Manual					   CPU_COREDUMP(9)

NAME
cpu_coredump -- machine-dependent process core dump interface
SYNOPSIS
#include <sys/signalvar.h> int cpu_coredump(struct lwp *l, void *iocookie, struct core *chdr); int cpu_coredump32(struct lwp *l, void *iocookie, struct core32 *chdr);
DESCRIPTION
cpu_coredump() is the machine-dependent interface invoked by machine-independent code to dump the machine-dependent header information at the start of a process core dump. The header information primarily consists of the CPU and floating-point registers. l is the lwp structure of the thread being dumped. iocookie is an opaque pointer to be passed to coredump_write(). Information about the machine-dependent header sections are returned in chdr. cpu_coredump() returns 0 on success and an appropriate error code on failure.
CODE REFERENCES
Process core dumps are initiated within the file sys/kern/kern_sig.c. Process core dumps for ELF NetBSD binaries are performed within the files sys/kern/core_elf32.c or sys/kern/core_elf64.c. Process core dumps for other NetBSD binaries are performed within the file sys/kern/core_netbsd.c.
SEE ALSO
coredump_write(9)
BSD
December 24, 2005 BSD
Related Man Pages
selinit(9) - netbsd
vfs_hooks_unmount(9) - netbsd
selnotify(9) - netbsd
vfs_hooks(9) - netbsd
core(5) - freebsd
Similar Topics in the Unix Linux Community
sorting left-justified numeric values
Memory Leaks
Make bold chars in UNIX
Adding a List of Times
Grep command to show the number of results