netbsd man page for bcopy

Query: bcopy

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BCOPY(9)						   BSD Kernel Developer's Manual						  BCOPY(9)

NAME
bcopy -- copy byte string
SYNOPSIS
#include <sys/systm.h> void bcopy(const void *src, void *dst, size_t len);
DESCRIPTION
The bcopy() interface is obsolete. Do not add new code using it. It will soon be purged. Use memcpy(9) instead. (The bcopy() function is now a macro for memcpy(9).) The bcopy() function copies len bytes from string src to string dst. Unlike bcopy(3) the two strings must not overlap! In the traditional BSD kernel, overlapping copies were handled by the now-purged ovbcopy() function. If you need to copy overlapping data, see memmove(9). If len is zero, no bytes are copied.
SEE ALSO
bcopy(3), memcpy(9), memmove(9)
BSD
July 7, 2001 BSD
Related Man Pages
bcopy(3) - linux
bcopy(3) - debian
bstring(3) - osx
bstring(3) - freebsd
bcopy(3) - posix
Similar Topics in the Unix Linux Community
Vobcopy 1.1.0 (Default branch)
Vobcopy 1.1.1 (Default branch)
Vobcopy 1.1.2 (Default branch)
Usbcopy fails with the error message sol-11_1-live-x86.usb is not a multiple of 512
[BASH] Floating point exception