|Linux & Unix Commands - Search Man Pages
WAKEONLAN(8) BSD System Manager's Manual WAKEONLAN(8)
wakeonlan -- send Wake on LAN frames to hosts on a local Ethernet network
wakeonlan [interface] lladdr [lladdr ...]
The wakeonlan program is used to send Wake on LAN (WoL) frames over a local Ethernet network
to one or more hosts using their link layer (hardware) addresses. WoL functionality is gen-
erally enabled in a machine's BIOS and can be used to power on machines from a remote system
without having physical access to them.
interface is an Ethernet interface of the local machine and is used to send the Wake on LAN
frames over it. If there is only one Ethernet device available that is up and running, then
the interface argument can be omitted. lladdr is the link layer address of the remote
machine. This can be specified as the actual hardware address (six hexadecimal numbers sep-
arated by colons) or as a hostname entry in /etc/ethers. wakeonlan accepts multiple lladdr
addresses. Link layer addresses can be determined and set using ifconfig(8).
/etc/ethers Ethernet host name data base.
wakeonlan was written by Marc Balmer <firstname.lastname@example.org>.
BSD May 25, 2012 BSD
All times are GMT -4. The time now is 03:10 PM.