UTMP_UPDATE(8) BSD System Manager's Manual UTMP_UPDATE(8)NAME
utmp_update -- update utmpx database
SYNOPSIS
utmp_update utmpx_entry
DESCRIPTION
utmp_update is a helper program to allow a user to update his own utmpx(5) entry. utmp_update does some consistency checks on the
strvis(3)-encoded utmpx_entry and then updates the utmpx(5) database of currently logged in users.
utmp_update should not be called directly, but will normally only be called by pututxline(3) if the privileges of the calling user are not
sufficient.
EXIT STATUS
utmp_update returns 0 on success, and 1 if an error occurred.
SEE ALSO pututxline(3), utmpx(5)BSD December 12, 2002 BSD
Check Out this Related Man Page
LOGIN(3) BSD Library Functions Manual LOGIN(3)NAME
login, logout, logwtmp -- login utility functions (DEPRECATED)
SYNOPSIS
#include <util.h>
void
login(struct utmp *ut);
int
logout(const char *line);
void
logwtmp(const char *line, const char *name, const char *host);
DESCRIPTION
The login(), logout(), and logwtmp() functions are DEPRECATED; use pututxline(3) instead.
These functions operate on the database of current users in /var/run/utmpx and the system log file. Superuser permission is required.
The login() function updates the /var/run/utmpx files with user information contained in ut (after converting to a struct utmpx, as described
in pututxline(3)).
The logout() function removes the entry from /var/run/utmpx corresponding to the device line.
The logwtmp() function adds an entry to the system log file. Since login() will add the appropriate entry during a login, logwtmp() is usu-
ally used for logouts.
RETURN VALUES
logout() returns non-zero if it was able to find and delete an entry for line, and zero if there is no entry for line in /var/run/utmpx.
However, there is no error indication due to lack of permissions.
FILES
/dev/*
/var/run/utmpx
SEE ALSO pututxline(3), utmp(5), utmpx(5)BSD December 14, 1995 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)