|Linux & Unix Commands - Search Man Pages
SSH-KEYSIGN(8) BSD System Manager's Manual SSH-KEYSIGN(8)
ssh-keysign -- ssh helper program for host-based authentication
ssh-keysign is used by ssh(1) to access the local host keys and generate the digital signa-
ture required during host-based authentication with SSH protocol version 2.
ssh-keysign is disabled by default and can only be enabled in the global client configura-
tion file /etc/ssh/ssh_config by setting EnableSSHKeysign to ``yes''.
ssh-keysign is not intended to be invoked by the user, but from ssh(1). See ssh(1) and
sshd(8) for more information about host-based authentication.
Controls whether ssh-keysign is enabled.
These files contain the private parts of the host keys used to generate the digital
signature. They should be owned by root, readable only by root, and not accessible
to others. Since they are readable only by root, ssh-keysign must be set-uid root
if host-based authentication is used.
If these files exist they are assumed to contain public certificate information cor-
responding with the private keys above.
ssh(1), ssh-keygen(1), ssh_config(5), sshd(8)
ssh-keysign first appeared in OpenBSD 3.2.
Markus Friedl <firstname.lastname@example.org>
BSD August 31, 2010 BSD
All times are GMT -4. The time now is 04:21 AM.