RTSOLD(8) BSD System Manager's Manual RTSOLD(8)
rtsold -- router solicitation daemon
rtsold [-1Ddfm] interface ...
rtsold [-1Ddfm] -a
rtsol [-Dd] interface ...
rtsol [-Dd] -a
rtsold is the daemon program to send ICMPv6 Router Solicitation messages on the specified
interfaces. If a node (re)attaches to a link, rtsold sends some Router Solicitations on the
link destined to the link-local scope all-routers multicast address to discover new routers
and to get non link-local addresses.
rtsold should be used on IPv6 hosts (non-router nodes) only.
If you invoke the program as rtsol, it will transmit probes from the specified interface,
without becoming a daemon. In other words, rtsol behaves as ``rtsold -f1 interface ...''.
Specifically, rtsold sends at most 3 Router Solicitations on an interface after one of the
o Just after invocation of the rtsold daemon.
o The interface is up after a temporary interface failure. rtsold detects such failures
by periodically probing to see if the status of the interface is active or not. Note
that some network cards and drivers do not allow the extraction of link state. In such
cases, rtsold cannot detect the change of the interface status.
o Every 60 seconds if the -m option is specified and the rtsold daemon cannot get the
interface status. This feature does not conform to the IPv6 neighbor discovery specifi-
cation, but is provided for mobile stations. The default interval for router advertise-
ments, which is on the order of 10 minutes, is slightly long for mobile stations. This
feature is provided for such stations so that they can find new routers as soon as pos-
sible when they attach to another link.
Once rtsold has sent a Router Solicitation, and has received a valid Router Advertisement,
it refrains from sending additional solicitations on that interface, until the next time one
of the above events occurs.
When sending a Router Solicitation on an interface, rtsold includes a Source Link-layer
address option if the interface has a link-layer address.
Upon receipt of signal SIGUSR1, rtsold will dump the current internal state into
/var/run/rtsold.dump. Also note that rtsold will not be able to update the kernel routing
tables unless sysctl(8) reports that net.inet6.ip6.accept_rtadv=1.
The options are as follows:
-1 Perform only one probe. Transmit Router Solicitation packets until at least one
valid Router Advertisement packet has arrived on each interface, then exit.
-a Autoprobe outgoing interface. rtsold will try to find a non-loopback, non-point-to-
point, IPv6-capable interface. If rtsold finds multiple interfaces, rtsold will
exit with an error.
-D Enable more debugging (than that offered by the -d option) including the printing of
internal timer information.
-d Enable debugging.
-f This option prevents rtsold from becoming a daemon (foreground mode). Warning mes-
sages are generated to standard error instead of syslog(3).
-m Enable mobility support. If this option is specified, rtsold sends probing packets
to default routers that have advertised Router Advertisements when the node
(re)attaches to an interface. Moreover, if the option is specified, rtsold periodi-
cally sends Router Solicitation on an interface that does not support the
The rtsold utility exits 0 on success, and >0 if an error occurs.
/var/run/rtsold.pid The PID of the currently running rtsold.
/var/run/rtsold.dump Internal state dump file.
The rtsold command is based on the rtsol command, which first appeared in the WIDE/KAME IPv6
protocol stack kit. rtsol is now integrated into rtsold.
In some operating systems, when a PCMCIA network card is removed and reinserted, the corre-
sponding interface index is changed. However, rtsold assumes such changes will not occur,
and always uses the index that it got at invocation. As a result, rtsold may not work if
you reinsert a network card. In such a case, rtsold should be killed and restarted.
You may see kernel error messages if you try to autoconfigure a host with multiple inter-
BSD January 11, 2010 BSD