|Linux & Unix Commands - Search Man Pages
PAM_RADIUS(8) BSD System Manager's Manual PAM_RADIUS(8)
pam_radius -- RADIUS PAM module
[service-name] module-type control-flag pam_radius [options]
The RADIUS service module for PAM provides authentication services based upon the RADIUS
(Remote Authentication Dial In User Service) protocol.
The pam_radius module accepts these optional parameters:
causes pam_radius to use a previously entered password instead of prompting for
a new one. If no password has been entered then authentication fails.
causes pam_radius to use a previously entered password, if one is available. If
no password has been entered, pam_radius prompts for one as usual.
echo_pass causes echoing to be left on if pam_radius prompts for a password.
specifies a non-standard location for the RADIUS client configuration file (nor-
mally located in /etc/radius.conf).
specifies a NAS identifier to send instead of the hostname.
specifies a user whose passwd(5) entry will be used as a template to create the
session environment if the supplied username does not exist in the local pass-
word database. The user will be authenticated with the supplied username and
password, but his credentials to the system will be presented as the ones for
username, i.e., his login class, home directory, resource limits, etc. will be
set to ones defined for username.
If this option is omitted, and there is no username in the system databases
equal to the supplied one (as determined by call to getpwnam(3)), the authenti-
cation will fail.
specifies a NAS IP address to be sent. If option is present, but there is no
value provided then IP address corresponding to the current hostname will be
/etc/radius.conf The standard RADIUS client configuration file for pam_radius
passwd(5), radius.conf(5), pam(8)
The pam_radius module first appeared in FreeBSD 3.1. The pam_radius manual page first
appeared in FreeBSD 3.3.
The pam_radius manual page was written by Andrzej Bialecki <abial@FreeBSD.org>.
The pam_radius module was written by John D. Polstra <jdp@FreeBSD.org>.
BSD October 28, 2002 BSD
All times are GMT -4. The time now is 11:24 PM.