PAM_LOGIN_ACCESS(8) BSD System Manager's Manual PAM_LOGIN_ACCESS(8)NAME
pam_login_access -- login.access PAM module
[service-name] module-type control-flag pam_login_access [options]
The login.access service module for PAM provides functionality for only one PAM category: account management. In terms of the module-type
parameter, this is the ``account'' feature.
Login.access Account Management Module
The login.access account management component (pam_sm_acct_mgmt()), returns success if and only if the user is allowed to log in on the spec-
ified tty (in the case of a local login) or from the specified remote host (in the case of a remote login), according to the restrictions
listed in /etc/login.access.
SEE ALSO login.access(5), pam.conf(5), pam(8)AUTHORS
The login.access(5) access control scheme was designed and implemented by Wietse Venema.
The pam_login_access module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research
Division of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
BSD January 24, 2002 BSD
Check Out this Related Man Page
PAM_GUEST(8) BSD System Manager's Manual PAM_GUEST(8)NAME
pam_guest -- Guest PAM module
[service-name] module-type control-flag pam_guest [arguments]
The guest service module for PAM allows guest logins. If successful, the pam_guest module sets the PAM environment variable GUEST to the
login name. The application can check this variable using pam_getenv(3) to differentiate guest logins from normal logins.
The following options may be passed to the pam_guest module:
guests=list Comma-separated list of guest account names. The default is ``guest''. A typical value for ftpd(8) would be
nopass Omits the password prompt if the target account is on the list of guest accounts.
pass_as_ruser The password typed in by the user is exported as the PAM_RUSER item. This is useful for applications like ftpd(8) where guest
users are encouraged to use their email address as password.
pass_is_user Requires the guest user to type in the guest account name as password.
SEE ALSO pam_get_item(3), pam_getenv(3), pam.conf(5), pam(8)AUTHORS
The pam_guest module and this manual page were developed for the FreeBSD Project by ThinkSec AS and NAI Labs, the Security Research Division
of Network Associates, Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (``CBOSS''), as part of the DARPA CHATS research program.
BSD May 26, 2003 BSD
I'm now playing with my RH Linux 7.3 installation on my laptop. I've installed the StarOffice suite from root login.
Now my problem:
I created a user account "vishnu".. but I cannot see the StarOffice in the menu listing of this user. How can I give "vishnu" the access to StarOffice... (4 Replies)
Hi, hope someone could help me here:
Our root account was disabled on our production server this morning and usually we would login at the console to re-enable the account. However we are unable to get a login prompt at the console. The console displays the 8 options along the bottom and a... (2 Replies)
Need your assistance/advice.
I have 4 folders but using same name log file.
filename is access.log.20060716.gz
I want to grep the transaction id in the log file but I want to do... (2 Replies)
How do you access a terminal and create a Unix user account. I am new to this form, so, is there a way to log on to a unix account that this forum offers to practice Unix. Is there a server available (somewhere) to users of this forum to access unix? So far the research I have found refers a person... (2 Replies)
I'm new to HP-UX. I have a system running B.11.23 on ia64. The system gets its user passwords via active directory. Everytime a new account is added to AD a script pushes out the account info to all the systems and this system is updated too. However, on this machine, users are unable to... (2 Replies)
I had asked my system admin to
Disable direct login for xxxx id since it was a generic ID.
If someone wanted to login to xxxx id on same system, they should initially login with their yyyy id(personal ID) and then su to xxxx userid.(wanted to track who had all logged in, it would be diffult... (6 Replies)
We have some HP unix servers and sometimes we logon there thru a dedicated Windows server that has Reflection X on it in case we need X. In this case we always need to export DISPLAY=winservername:0.0
I want to automate this thing in .profile file. If e.g. $TERM = hpterm (thru... (2 Replies)
hello, I am trying to log on and get an error "3004-304 You are not allowed to login at this time.".
The server is in production level, works as a cluster under hacmp, the other server took the services but I cannot log into the first one.
Please help me because I need to solve the problem as... (2 Replies)
I have a question on the UNIX server login with putty.
Can this login procedure into PUTTY be automated with a macro or vbs or batch file?
Kindly help me in directing me for the above.
Thanks for the help,
Regards, (3 Replies)
How to find remote Linux box login account without login in to that box?
I don't have login account at my remote Linux box. But I need who are all having login account. How do I findout?
--Muthu. (3 Replies)
hi gyus, i'm trying to login trough GUI (using login screen, instead to login to locahost I login to remote host) from on Solaris 10 to another one.
You know, I see the remote host in the host list, but It's not possible to login since the screen keeps black and after that get back to the former... (3 Replies)
Hi, I need some help regarding login issue. I have to use 8 server. The username is same at all. But when i was trying to access for particular 4 server. I got access denied error. Please help ....
Note: If i change my password by using root user. then I can able to enter into the same server.... (6 Replies)
I'm using RedHat Linux 6.1 and wanted to create an user account with only access to single directory. Have followed all the steps from below link and still user is not able to login:
How to Setup Chroot SFTP in Linux (Allow Only SFTP, not SSH) (link removed)
While the other users, which... (10 Replies)