OFCTL(8) BSD System Manager's Manual OFCTL(8)NAME
ofctl -- display the OpenPROM or OpenFirmware device tree
ofctl [-p] [-f file] [node]
ofctl provides an interface for displaying the OpenPROM or OpenFirmware device tree and node properties. The ofctl program is only installed
on supported platforms.
Without any arguments, ofctl will dump the full tree. When given the name of a specific node, ofctl will display that node and its child
The options are as follows:
-f file On systems with OpenPROM, use file instead of the default /dev/openprom. On systems with OpenFirmware, use file instead of
the default /dev/openfirm.
-p Display each node's properties.
/dev/openprom The openprom device on systems with OpenPROM.
/dev/openfirm The openfirm device on systems with OpenFirmware.
SEE ALSO eeprom(8)BSD September 29, 2006 BSD
Check Out this Related Man Page
NG_DEVICE(4) BSD Kernel Interfaces Manual NG_DEVICE(4)NAME
ng_device -- device netgraph node type
A device node is both a netgraph node and a system device interface. When a device node is created, a new device entry appears which is
accessible via the regular file operators such as open(2), close(2), read(2), write(2), etc.
The first node is created as /dev/ngd0, all subsequent nodes /dev/ngd1, /dev/ngd2, etc.
A device node has a single hook with an arbitrary name. All data coming in over the hook will be presented to the device for read(2). All
data coming in from the device entry by write(2) will be forwarded to the hook.
The device node supports one non-generic control message:
Returns device name corresponding to a node.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or upon hook disconnection. The associated device entry is removed and
becomes available for use by future device nodes.
SEE ALSO netgraph(4), ngctl(8)HISTORY
The device node type was first implemented in FreeBSD 5.0.
Mark Santcroos <email@example.com>
Gleb Smirnoff <glebius@FreeBSD.org>
BSD October 19, 2004 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)