NetBSD 6.1.5 - man page for mount_overlay (netbsd section 8)
|Linux & Unix Commands - Search Man Pages
MOUNT_OVERLAY(8) BSD System Manager's Manual MOUNT_OVERLAY(8)
mount_overlay -- mount an overlay filesystem; demonstrate the use of an overlay file system
mount_overlay [-o options] /overlay mount-point
The mount_overlay command creates an overlay layer, interposing the overlay filesystem
between the over-mounted file store and future pathname lookups.
A different device number for the virtual copy is returned by stat(2), but in other respects
it is indistinguishable from the original.
The mount_overlay filesystem differs from the null filesystem in that the mount_overlay
filesystem does not replicate the sub-tree, it places itself between the sub-tree and all
The overlay layer has two purposes. First, it serves as a demonstration of layering by pro-
viding a layer which does nothing other than insert itself over the over-mounted file sys-
tem. Second, the overlay layer can serve as a prototype layer. Since it provides all nec-
essary layer framework, new file system layers which need to block access to the overlayed
file system can be created very easily by starting with an overlay layer.
The internal operation of the overlay layer is identical to that of the null layer. See its
documentation for details.
UCLA Technical Report CSD-910056, Stackable Layers: an Architecture for File System
The mount_overlay utility first appeared in NetBSD 1.5.
BSD January 18, 2000 BSD
All times are GMT -4. The time now is 08:22 PM.