MOUNT_OVERLAY(8) BSD System Manager's Manual MOUNT_OVERLAY(8)NAME
mount_overlay -- mount an overlay filesystem; demonstrate the use of an overlay file system layer
mount_overlay [-o options] /overlay mount-point
The mount_overlay command creates an overlay layer, interposing the overlay filesystem between the over-mounted file store and future path-
A different device number for the virtual copy is returned by stat(2), but in other respects it is indistinguishable from the original.
The mount_overlay filesystem differs from the null filesystem in that the mount_overlay filesystem does not replicate the sub-tree, it places
itself between the sub-tree and all future access.
The overlay layer has two purposes. First, it serves as a demonstration of layering by providing a layer which does nothing other than
insert itself over the over-mounted file system. Second, the overlay layer can serve as a prototype layer. Since it provides all necessary
layer framework, new file system layers which need to block access to the overlayed file system can be created very easily by starting with
an overlay layer.
The internal operation of the overlay layer is identical to that of the null layer. See its documentation for details.
SEE ALSO mount(8), mount_null(8)
UCLA Technical Report CSD-910056, Stackable Layers: an Architecture for File System Development.
The mount_overlay utility first appeared in NetBSD 1.5.
BSD January 18, 2000 BSD
Check Out this Related Man Page
glutOverlayDisplayFunc(3GLUT) GLUT glutOverlayDisplayFunc(3GLUT)NAME
glutOverlayDisplayFunc - sets the overlay display callback for the current window.
void glutOverlayDisplayFunc(void (*func)(void));
func The new overlay display callback function.
glutDisplayFunc sets the overlay display callback for the current window. The overlay display callback is functionally the same as the win-
dow's display callback except that the overlay display callback is used to redisplay the window's overlay.
When GLUT determines that the overlay plane for the window needs to be redisplayed, the overlay display callback for the window is called.
Before the callback, the current window is set to the window needing to be redisplayed and the layer in use is set to the overlay. The
overlay display callback is called with no parameters. The entire overlay region should be redisplayed in response to the callback (this
includes ancillary buffers if your program depends on their state).
GLUT determines when the overlay display callback should be triggered based on the window's overlay redisplay state. The overlay redisplay
state for a window can be either set explicitly by calling glutPostOverlayRedisplay or implicitly as the result of window damage reported
by the window system. Multiple posted overlay redisplays for a window are coalesced by GLUT to minimize the number of overlay display call-
Upon return from the overlay display callback, the overlay damaged state of the window (returned by calling glutLayerGet(GLUT_OVERLAY_DAM-
AGED) is cleared.
The overlay display callback can be deregistered by passing NULL to glutOverlayDisplayFunc. The overlay display callback is initially NULL
when an overlay is established. See glutDisplayFunc to understand how the display callback alone is used if an overlay display callback is
Mark J. Kilgard (firstname.lastname@example.org)
GLUT 3.7 glutOverlayDisplayFunc(3GLUT)
I'm a windows user..........
I got a hard drive that windows recognize as a RAS FS ....and I don't know what is RAW file system ... can you help me guys ???
is there any way that I can access the data written on this drive from windows 2000 operations system ???
Thanks & Best... (1 Reply)
i m new user in this forum....i need ur help :confused: . Can anyone tell me which Operating System from Linux, Unix,FreeBSD,MacOSX, and Solaris.... has the best file System? and Y it is best for this OS?
regards.... (1 Reply)