Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

modstat(8) [netbsd man page]

MODSTAT(8)						    BSD System Manager's Manual 						MODSTAT(8)

NAME
modstat -- display status of loaded kernel modules SYNOPSIS
modstat [-n] [name] DESCRIPTION
The modstat utility displays the status of any kernel modules present in the kernel. The options are as follows: -n name Display the status of only the module with this name. Please note that -n is optional. In addition to listing the currently loaded modules' name, the information reported by modstat includes: CLASS Module class, such as "vfs", "driver", "exec", "misc" or "secmodel". SOURCE Where the module was loaded from. "builtin" indicates that the module was built into the running kernel. "boot" indicates that the module was loaded during system bootstrap. "filesys" indicates that the module was loaded from the file system. SIZE Size of the module in bytes. REFS Number of references held on the module. Disabled builtin modules will show a count of -1 here. REQUIRES Additional modules that must be present. EXIT STATUS
The modstat utility exits with a status of 0 on success and with a nonzero status if an error occurs. SEE ALSO
module(7), modload(8), modunload(8) HISTORY
The modstat command was designed to be similar in functionality to the corresponding command in SunOS 4.1.3. BSD
August 2, 2011 BSD

Check Out this Related Man Page

MODSTAT(2)                                                    BSD System Calls Manual                                                   MODSTAT(2)

NAME
modstat -- get status of kernel module LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <sys/param.h> #include <sys/module.h> int modstat(int modid, struct module_stat *stat); DESCRIPTION
The modstat() system call writes the info for the kernel module referred to by modid into stat. struct module_stat { int version; /* set to sizeof(module_stat) */ char name[MAXMODNAME]; int refs; int id; modspecific_t data; }; typedef union modspecific { int intval; u_int uintval; long longval; u_long ulongval; } modspecific_t; version This field is set to the size of the structure mentioned above by the code calling modstat(), and not modstat() itself. name The name of the module referred to by modid. refs The number of modules referenced by modid. id The id of the module specified in modid. data Module specific data. RETURN VALUES
The modstat() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. ERRORS
The information for the module referred to by modid is filled into the structure pointed to by stat unless: [ENOENT] The module was not found (probably not loaded). [EINVAL] The version specified in the version field of stat is not the proper version. You would need to rebuild world, the ker- nel, or your application, if this error occurs, given that you did properly fill in the version field. [EFAULT] There was a problem copying one, some, or all of the fields into stat in the copyout(9) function. SEE ALSO
kldfind(2), kldfirstmod(2), kldload(2), kldnext(2), kldstat(2), kldsym(2), kldunload(2), modfind(2), modfnext(2), modnext(2), kld(4), kldstat(8) HISTORY
The kld interface first appeared in FreeBSD 3.0. BSD July 15, 2008 BSD
Man Page