LINK(8) BSD System Manager's Manual LINK(8)NAME
link -- call the link() function
link file1 file2
The link utility performs the function call link(file1, file2).
file1 must be the pathname of an existing file, and file2 is the pathname of the new link to file1 to be created.
The link utility exits 0 on success, and >0 if an error occurs.
SEE ALSO ln(1), link(2), unlink(8)STANDARDS
The link utility conforms to X/Open Commands and Utilities Issue 5 (``XCU5'').
BSD July 18, 1999 BSD
Check Out this Related Man Page
link(1) General Commands Manual link(1)NAME
link, unlink - Creates an additional directory entry for an existing file
link file1 file2
Interfaces documented on this reference page conform to industry standards as follows:
Refer to the standards(5) reference page for more information about industry standards and associated tags.
The link command performs the link() system call to create an additional directory entry for an existing file, file1. In effect, the
underlying file then has two names, file1 and file2 (either of these arguments can be a pathname). The old and new entries share equal
access rights to the underlying file.
The unlink command performs the unlink() system call to remove a link to file created by link. The unlink command removes the directory
entry specified by the file parameter and, if the entry is a hard link, decrements the link count of the file referenced by the link.
You should be familiar with the link() and unlink() system calls before you use these commands.
The link and unlink commands do not issue error messages when the associated system call is unsuccessful.
The link and unlink commands cannot be used to link and unlink directories.
The link and unlink commands both exit with the following: The link() or unlink() system call succeeded. Too few or too many arguments
specified. The link() or unlink() system call failed.
Commands: fsck(8), ln(1)
Functions: link(2), unlink(2)link(1)
I wouldn't say I'm a unix dummy, or a unix expert, but I have few other options. So I installed MkLinux on an old powermac 6100 I had around. I got it up and running too, its on my network, its apache web server works (though I need to install PHP) I downloaded the RC5-72 client and it runs great.... (25 Replies)
First off I try to install XTheater on SuSE 9.2 Pro I run the ./configure command and this is what I get
loading cache ./config.cache
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking whether build environment is... (25 Replies)
Hi Can any one help me remove the unwanted data? I would want to remove the complete event id 4910 ( the type there is INFO), that means, I have to remove starting from 7th - 19th lines. can any one of you please help?
Thanks, (24 Replies)
Greetings, :rolleyes: :o :confused:
I am working on Solaris 8. I have a few questions:
1. How do I determine if I have the CC compiler? I know it isn't in my $PATH, so how do I find it?
2. How do you install wget? I have read the INSTALL file, but I am not familar with the switches,... (25 Replies)
Ultra E150 Solaris 2.5.1 Oracle server. was working fine, then started losing network connection. I can see in messages file that it was complaining about another device using its ip address. Though not any longer, though I wonder if that was a red herring. My IT guys have now re-reserved its ip... (29 Replies)
Hi guys, i am new to perl. I started reading the perl documents and try to come up with some logic.
I am trying to create a script that would go into a location, search for todays files, then searches for all .txt files from today.
If todays not found, its an error
If file size is less... (26 Replies)
This is the source code:
using namespace std;
struct passwd *user;
char login="alex", password="qwertyuiop";
if ((user= getpwnam(login)) == NULL)
cout << "No such user\n";
else if... (24 Replies)
Hi everyone. I would like to hook a system function (gettimeofday) to modify it. I guess I'll need kernel mode to do that. By the way, how could I do it (c++ or c)?
I want to modify that function for one process which I know the PID. So I need to return my own value for that PID and real value... (29 Replies)
Incompatiblity of the code due to CC compiler version mismatch.
I have a machine with
Machine A-- Operating System:SunOs 5.8 Generic_117350-45 sun4u sparc SUNW,Ultra-80(solaris 5.8)
CC Compiler:CC: WorkShop Compilers 4.2 16 Jun 1998 C++ 4.2 patch 104631-07
we have compiled C++... (36 Replies)
Hello, I am trying to concatenate two strings by merging the overlapped region. E.g.
Seq_merged=ACGTGCCCCCGTGTGTGTFunction strcat(char *dest, char *src) appends the src string to the dest string, ignoring the overlapped parts (prefix of src and suffix of dest).... (30 Replies)