LDPD(8) BSD System Manager's Manual LDPD(8)NAME
ldpd -- Label Distribution Protocol Daemon
ldpd [-DdfhW] [-c config_file] [-p port]
ldpd is a utility used to automatically distribute labels between two MPLS LSRs almost conforming to RFC3036. Right now it is in BETA stage
and many features are not implemented or may not work. As a security measure you SHOULD filter the LDP well-known (646) TCP and UDP ports
using your favourite packet filter before starting ldpd. Also this is the current measure used to filter neighbours. You should see some
logs reported via syslog(3) interface.
You can increase the log verbosity using the -W and -D flags. Also you can telnet to the control port (default: 2626) and use this interface
in order to get informations about protocol, neighbours etc. but also to set runtime parameters. The required password is the same as the
ldpd computes existing routes and tries to match them on MPLS labels announced by other LDP peers. This means that ``normal'' routes will be
changed into tagged routes, and MPLS routing table will be populated. It will also announce its mappings to its peers. ldpd will listen on
a route socket and compute the necessary changes in order to change untagged routes into tagged routes. This means that one may use one's
favourite dynamic routing protocol daemon without modifications.
The options are as follows:
-c config_file Specifies a path to the config file. Default: /etc/ldpd.conf - see ldpd.conf(5) for configuration file format.
-D Enable debug mode.
-d Don't use route interception code.
-f Run in foreground. Use STDOUT for warning and debug messages.
-h Outputs supported flags.
-p port Changes the TCP control port (default: 2626).
-W Enable output of warning messages.
LDP Specification, RFC, 3036, January 2001.
LDP Applicability, RFC, 3037, January 2001.
The ldpd command appeared in NetBSD 6.0.
ldpd supports only IPv4 and doesn't implement Path Vector and Hop Count TLVs.
BSD July 7, 2011 BSD
Check Out this Related Man Page
gated - gateway routing daemon
buffer_size] trace_options] config_file] [trace_file]
is a routing daemon that handles multiple routing protocols and replaces routed, egpup, and any routing daemon that speaks the HELLO rout-
ing protocol. currently handles the RIP, BGP, EGP, HELLO, and OSPF routing protocols. The process can be configured to perform all rout-
ing protocols or any subset of them (see below).
The command-line options are:
Specifies a buffer size for the socket read/write buffer. The buffer size should not be less than one MB (megabyte) and should not exceed
the available system memory. If this option is not specified, the buffer size will be set to the available system memory.
Specifies that the configuration file will be parsed for syntax errors
and then will exit. will leave a dump file in if there were no errors. does not need to be run as the superuser to use the option
but it may not be possible to read the kernel forwarding table and interface configuration if not run as superuser. The option
implies All trace_option clauses in the configuration file will be ignored.
Specifies that the configuration file will just be parsed for syntax
errors. will exit with a status 1 if there were any errors and 0 (zero) if there were not. does not need to be run as the supe-
ruser to use the option but it may not be possible to read the kernel forwarding table and interface configuration if not run as the
will not modify the kernel forwarding table. This is used for testing configurations with actual routing data.
will not daemonize. Normally, if tracing to stderr is not specified will daemonize if the parent process ID is not that of the ini-
tialization process (aka This allows the use of an method of invoking that does not have a PID of the initialization process.
will add routes to the kernel in the decreasing order of IP addresses of gateways when there are multiple routes to a destination.
Specifies a comma separated list of
trace options to be enabled on startup. If no flags are specified, is assumed. No space is allowed between this option and it's
This option must be used to trace events that take place before the configuration file is parsed, such as determining the interface
configuration and reading routes from the kernel.
See the for valid trace options and a more detailed explanation of tracing.
Use an alternate config file. By default,
Trace file in which to place trace information.
If a trace file is specified on the command line, or no trace flags are specified on the command line, detaches from the terminal
and runs in the background. If trace flags are specified without specifying a trace file, assumes that tracing is desired to stderr
and remains in the foreground.
The following signals may be used to control
A causes to reread the configuration file. first performs a clean-up of all allocated policy structures. All BGP and
EGP peers are flagged for deletion and the configuration file is re-parsed.
If the re-parse is successful, any BGP and EGP peers that are no longer in the configuration are shut down, and new
peers are started. attempts to determine if changes to existing peers require a shutdown and restart. OSPF is not
capable of reconfiguring; it is shutdown and restarted during a reconfiguration. This may have an adverse impact on the
It should also be possible to enable/disable any protocol without restarting
Snap-shot of current state.
The current state of all tasks, timers, protocols and tables are written to
On systems supporting this is done by forking a subprocess to dump the table information so as not to impact routing
functions. On systems where memory management does not support copy-on-write, this will cause the address space to be
duplicated; this may cause a noticeable impact on the system. On system not supporting the main process immediately
processes the dump, which may impact routing functions.
On receipt of a attempts a graceful shutdown. All tasks and protocols are asked to shutdown. Most will terminate imme-
diately, the exception being EGP peers which wait for confirmation. It may be necessary to repeat the once or twice if
it this process takes too long.
All protocol routes are removed from the kernel's routing table on receipt of a Interface routes, routes with RTF_STATIC
set (from the route command where supported) and static routes specifying will remain. To terminate with the exterior
routes intact, use
On receipt of a will close the trace file. A subsequent will cause it to be reopened. This will allow the file to be
It is not possible to use if a trace file has not been specified, or tracing is being performed to stderr.
Check for interface changes.
On receipt of a will rescan the kernel interface list looking for changes.
contains provisions for BGP protocol, but it is not officially supported by HP at the present time. Some RIP version 2 features (RFC1388)
are not currently supported: MIB and route tag. The optional OSPF version 2 (RFC1247) feature of TOS (type of service) based routing is
not supported. The route aggregation, generating a more general route from compressing the specific routes through the explicit configu-
ration, is not supported in this release.
was primarily developed by Cornell University which includes code from the Regents of the University of California and the University of
This software and associated documentation is Copyright 1990, 1991, 1992 by Cornell University.
SEE ALSO gated.conf(4), arp(1M), fork(2), gdc(1M), ifconfig(1M), netstat(1), ospf_monitor(1M), ripquery(1M),
RFC 891 DCN Local-Network Protocols (HELLO)
RFC 904 Exterior Gateway Protocol Formal Specification
RFC 1058 Routing Information Protocol
RFC 1163 A Border Gateway Protocol (BGP)
RFC 1164 Application of the Border Gateway Protocol in the Internet
RFC 1247 OSPF Specification, Version 2.