KSTASH(8) BSD System Manager's Manual KSTASH(8)NAME
kstash -- store the KDC master password in a file
kstash [-e string | --enctype=string] [-k file | --key-file=file] [--convert-file] [--random-key] [--master-key-fd=fd] [--random-key]
[-h | --help] [--version]
kstash reads the Kerberos master key and stores it in a file that will be used by the KDC.
-e string, --enctype=string
the encryption type to use, defaults to DES3-CBC-SHA1.
-k file, --key-file=file
the name of the master key file.
don't ask for a new master key, just read an old master key file, and write it back in the new keyfile format.
generate a random master key.
filedescriptor to read passphrase from, if not specified the passphrase will be read from the terminal.
/var/heimdal/m-key is the default keyfile if no other keyfile is specified. The format of a Heimdal master key is the same as a keytab, so
ktutil list can be used to list the content of the file.
SEE ALSO kdc(8)BSD April 10, 2007 BSD
Check Out this Related Man Page
HPROP(8) BSD System Manager's Manual HPROP(8)NAME
hprop -- propagate the KDC database
hprop [-m file | --master-key=file] [-d file | --database=file] [--source=heimdal|mit-dump] [-r string | --v4-realm=string] [-c cell |
--cell=cell] [-k keytab | --keytab=keytab] [-R string | --v5-realm=string] [-D | --decrypt] [-E | --encrypt] [-n | --stdout]
[-v | --verbose] [--version] [-h | --help] [host[:port]] ...
hprop takes a principal database in a specified format and converts it into a stream of Heimdal database records. This stream can either be
written to standard out, or (more commonly) be propagated to a hpropd(8) server running on a different machine.
If propagating, it connects to all hosts specified on the command by opening a TCP connection to port 754 (service hprop) and sends the data-
base in encrypted form.
-m file, --master-key=file
Where to find the master key to encrypt or decrypt keys with.
-d file, --database=file
The database to be propagated.
Specifies the type of the source database. Alternatives include:
heimdal a Heimdal database
mit-dump a MIT Kerberos 5 dump file
+.It Fl k Ar keytab , Fl Fl keytab= Ns Ar keytab The keytab to use for fetching the key to be used for authenticating to the propaga-
tion daemon(s). The key hprop/hostname is used from this keytab. The default is to fetch the key from the KDC database.
-R string, --v5-realm=string
Local realm override.
The encryption keys in the database can either be in clear, or encrypted with a master key. This option transmits the database with
This option transmits the database with encrypted keys.
Dump the database on stdout, in a format that can be fed to hpropd.
The following will propagate a database to another machine (which should run hpropd(8)):
$ hprop slave-1 slave-2
SEE ALSO hpropd(8)HEIMDAL December 8, 2004 HEIMDAL
I have a system with the last version of AIX 5.3ML2 on which I installed nim master (nim_master_setup).
After the installation (NIM master setup is complete - enjoy! I like this message :D ) , I check the level of my systems it looks bad some filesets are missing for ML1 and ML2 (and... (1 Reply)
Is there an easy way to generate a random list from a give list of names? Let's say, I have a file containing 15000 city name of world(spreadsheet, names in the first column), I would like to randomly pick up 50 cities each time for total 1000 picks. Or doesn't anyone know a... (3 Replies)
consider this file "master" which contains data as
I am trying to enter data into the file "master"
i want to count the number of times 11 is present in the file "master" that to in the first filed... (5 Replies)
I have a list of ids and a master list. I need to display entries from the master list matching ids in the first list. The master list is space delimited, id is 1st field.
$ cat id_list
$ cat master_list
1 one detail1 detail2
2 two detail1 avg1 detail2 avg2
... etc ...
... (3 Replies)
I need help with nim ..
I am install nim master in may ambient.
# lsnim -l master
class = machines
type = master
max_nimesis_threads = 20
comments = machine which controls the NIM environment
global_export ... (2 Replies)
We have an interactive program from a 3rd party. We don't have the code. When I execute some of its commands through telnet, it complains, "Command must be executed from master console". Can executing this program from a shell through telnet get around this problem? Can cron get around this? Thanks. (1 Reply)
I'm newbie with HP-UX. My Unix install with DB Oracle. In linux, when we type directory we don't need to type full. We can use Tab key. In Unix, i cannot use Tab key and i need to write whole directory. Other thing, how use Arrow key in Unix? I mean use command already i type.
Is it... (1 Reply)
I'm a complete shell scripting newbie and need some help with comparing a file against a master file and outputting the results.
master.txt would look something like this:
file.txt would look like... (1 Reply)
I have created VIO Server which serves 3 lpars. All of them are on VLAN ID 50.
From one lpar I installed and set up NIM master server called testAIX1.
I have created client and allocated resources to it:
testAIX1:/ > lsnim -l test_lpar
class = machines
... (4 Replies)
suppose a key string: M0271857
and to find all lines containing this key string in a text file
which returns multiple lines
but i only want the shortest one
is there a way to do that?
thanks so much! (4 Replies)
I've a master file which will contain 100 file names, The script should read file name from a master file and format the file as below in AIX.
Filename|This is a test file
Thanks in advance
for file in $FileList; do (5 Replies)
I am setting up a cluster of Mac Pro's which need to be able to talk to a master computer, traffic between the nodes and the master needs to take place without a ssh key. I need a script that will create a security key, save it to the default place, enter the password as no password.... (2 Replies)
hii master Unix
I finish find to google how to command for the show part number and asset number at a IBM P series and i notyet finded.
maybe all master unix can help me about what the command part number and asset number at server IBM P series.
amin (1 Reply)