|Linux & Unix Commands - Search Man Pages
KGMON(8) BSD System Manager's Manual KGMON(8)
kgmon -- generate a dump of the operating system's profile buffers
kgmon [-bdhpr] [-M core] [-N system]
kgmon is a tool used when profiling the operating system. When no arguments are supplied,
kgmon indicates the state of operating system profiling as running, off, or not configured
(see config(1)). If the -p flag is specified, kgmon extracts profile data from the operat-
ing system and produces a gmon.out file suitable for later analysis by gprof(1).
The options are as follows:
-b Resume the collection of profile data.
-d Enable debug output.
-h Stop the collection of profile data.
Extract values associated with the name list from the specified core instead of the
Extract the name list from the specified system instead of the default /netbsd.
-p Dump the contents of the profile buffers into a gmon.out file.
-r Reset all the profile buffers. If the -p flag is also specified, the gmon.out file
is generated before the buffers are reset.
If neither -b nor -h is specified, the state of profiling collection remains unchanged. For
example, if the -p flag is specified and profile data is being collected, profiling will be
momentarily suspended, the operating system profile buffers will be dumped, and profiling
will be immediately resumed.
/netbsd the default system
/dev/kmem the default memory
Users with only read permission on /dev/kmem cannot change the state of profiling collec-
tion. They can get a gmon.out file with the warning that the data may be inconsistent if
profiling is in progress.
The kgmon command appeared in 4.2BSD.
BSD June 6, 1993 BSD
All times are GMT -4. The time now is 10:55 AM.