HPROPD(8) BSD System Manager's Manual HPROPD(8)NAME
hpropd -- receive a propagated database
hpropd [-d file | --database=file] [-n | --stdin] [--print] [-i | --no-inetd] [-k keytab | --keytab=keytab] [-4 | --v4dump]
hpropd receives a database sent by hprop. and writes it as a local database.
By default, hpropd expects to be started from inetd if stdin is a socket and expects to receive the dumped database over stdin otherwise. If
the database is sent over the network, it is authenticated and encrypted. Only connections authenticated with the principal kadmin/hprop are
-d file, --database=file
read from stdin
print dump to stdout
not started from inetd
-k keytab, --keytab=keytab
keytab to use for authentication
create v4 type DB
SEE ALSO hprop(8)BSD August 27, 1997 BSD
Check Out this Related Man Page
HPROP(8) BSD System Manager's Manual HPROP(8)NAME
hprop -- propagate the KDC database
hprop [-m file | --master-key=file] [-d file | --database=file] [--source=heimdal|mit-dump] [-r string | --v4-realm=string] [-c cell |
--cell=cell] [-k keytab | --keytab=keytab] [-R string | --v5-realm=string] [-D | --decrypt] [-E | --encrypt] [-n | --stdout]
[-v | --verbose] [--version] [-h | --help] [host[:port]] ...
hprop takes a principal database in a specified format and converts it into a stream of Heimdal database records. This stream can either be
written to standard out, or (more commonly) be propagated to a hpropd(8) server running on a different machine.
If propagating, it connects to all hosts specified on the command by opening a TCP connection to port 754 (service hprop) and sends the data-
base in encrypted form.
-m file, --master-key=file
Where to find the master key to encrypt or decrypt keys with.
-d file, --database=file
The database to be propagated.
Specifies the type of the source database. Alternatives include:
heimdal a Heimdal database
mit-dump a MIT Kerberos 5 dump file
+.It Fl k Ar keytab , Fl -keytab= Ns Ar keytab The keytab to use for fetching the key to be used for authenticating to the propaga-
tion daemon(s). The key hprop/hostname is used from this keytab. The default is to fetch the key from the KDC database.
-R string, --v5-realm=string
Local realm override.
The encryption keys in the database can either be in clear, or encrypted with a master key. This option transmits the database with
This option transmits the database with encrypted keys.
Dump the database on stdout, in a format that can be fed to hpropd.
The following will propagate a database to another machine (which should run hpropd(8)):
$ hprop slave-1 slave-2
SEE ALSO hpropd(8)BSD December 8, 2004 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)