|Linux & Unix Commands - Search Man Pages
HOSTAPD_CLI(8) BSD System Manager's Manual HOSTAPD_CLI(8)
hostapd_cli -- text-based frontend program for interacting with hostapd(8)
The hostapd_cli utility is a text-based frontend program for interacting with hostapd(8).
It is used to query the current status.
The hostapd_cli utility can show the current authentication status, dot11 and dot1x MIBs,
The hostapd_cli utility supports two modes: interactive and command line. Both modes share
the same command set.
Interactive mode is started when hostapd_cli is executed without any parameters on the com-
mand line. Commands are then entered from the controlling terminal in response to the
hostapd_cli prompt. In command line mode, the same commands are entered as command line
The following commands may be supplied on the command line or at a prompt when operating
mib Report MIB variables (dot1x, dot11) for the current interface.
Report the MIB variables for the associated station with MAC address addr.
Report the MIB variables for all associated stations.
help Show usage help.
Show available interfaces and/or set the current interface when multiple are avail-
Change the debugging level in hostapd(8). Larger numbers generate more messages.
Display the full license for hostapd_cli.
quit Exit hostapd_cli.
The hostapd_cli utility first appeared in NetBSD 4.0.
The hostapd_cli utility was written by Jouni Malinen <email@example.com>. This manual page
is derived from the README file included in the hostapd distribution.
BSD June 16, 2005 BSD
All times are GMT -4. The time now is 06:54 AM.