GSPA(8) BSD System Manager's Manual GSPA(8)NAME
gspa -- assembler for the GSP chip
gspa [-c c_array_name] [-l list_file] [-o hex_file] [infile]
gspa is an assembler for the TMS34010 and TMS34020 graphics processor chips.
The supported options are:
Create a pre-initialized C-structure c_array_name with the hex code of the assembler output.
Create commented (with the input file) hex code of the assembler output in list_file.
-o hex_file Create the output in hex_file. If -c is used, C code will be written to hex_file, otherwise uncommented hex code of the assem-
bler output will be written.
If no -o option is given, output will be written to stdout.
If no infile is given, input will be read from stdin.
gspa appeared in NetBSD 1.1.
gspa was written by Paul Mackerras. The -c mode was added by
Ignatios Souvatzis <is@NetBSD.org>. This man page was written by
Thomas Klausner <wiz@NetBSD.org>.
BSD May 27, 2002 BSD
Check Out this Related Man Page
UNIUNMASK(1) General Commands Manual UNIUNMASK(1)NAME
uniunmask - XOR bits or substitute glyphs in a GNU Unifont file.
uniunmask [-iinput_file] [-ooutput_file]
uniunmask reads a GNU Unifont .hex file. As it reads the font file, it scans for code points matching entries in the "masks.hex" and "sub-
stitutes.hex" files. "masks.hex" and "substitutes.hex" are also in GNU Unifont .hex format, ordered by Unicode code point (the hexadecimal
number to the left of the colon on each line).
If a code point is encountered from "substitutes.hex", the input code point in the original .hex file is ignored (as is any entry with the
same code point in "masks.hex") and the glyph from "substitutes.hex" is written to the output file.
Otherwise, if a code point is encountered from "masks.hex", the input glyph in the original .hex file is XORed with the bits in the
"masks.hex" entry. The result of this XOR operation is written to the output file.
OPTIONS -i Specify the input file. The default is stdin.
-o Specify the output file. The default is stdout.
masks.hex, substitutes.hex, *.hex GNU Unifont font files
SEE ALSO bdfimplode(1), hex2bdf(1), hex2bdf-split(1), hex2sfd(1), hexbraille(1), hexdraw(1), hexmerge(1), johab2ucs2(1), unibmp2hex(1), unicover-
age(1), unidup(1), unihex2bmp(1), unipagecount(1)AUTHOR
uniunmask was written by Paul Hardy.
uniunmask is Copyright (C) 2007 Paul Hardy, and is released under version 2 of the GNU General Public License, or (at your option) a later
No known real bugs exist, except that this software does not perform extensive error checking on its input files. If they're not in the
format of the original GNU Unifont hex file, all bets are off.
2008 Jul 6 UNIUNMASK(1)