|Linux & Unix Commands - Search Man Pages
FSIRAND(8) BSD System Manager's Manual FSIRAND(8)
fsirand -- install random inode generation numbers in a filesystem
fsirand [-F] [-p] [-x constant] special
fsirand writes random inode generation numbers for all the inodes on device special. These
random numbers make the NFS filehandles less predictable, increasing security of exported
fsirand should be run on a clean and unmounted filesystem.
The options are as follows:
-F Indicates that special is a file system image, rather than a device name. special
will be accessed 'as-is', without requiring that it is a raw character device and
without attempting to read a disklabel.
-p Print the current inode generation numbers; the filesystem is not modified.
Exclusive-or the given constant with the random number used in the generation
fsirand exits zero on success, non-zero on failure.
If fsirand receives a SIGINFO signal, statistics on the amount of work completed and esti-
mated completion time (in minutes:seconds) will be written to the standard error output.
BSD November 16, 2001 BSD
All times are GMT -4. The time now is 10:27 AM.