DEV_MKDB(8) BSD System Manager's Manual DEV_MKDB(8)NAME
dev_mkdb -- create /dev database
dev_mkdb [-c] [-o database] [directory]
The dev_mkdb command creates a cdbr(3) database in ``/var/run/dev.cdb'' which contains the names of all of the character and block special
files in the specified directory, using the file type and the st_rdev field as the key. If no directory is specified, the ``/dev'' directory
Keys are a structure containing a mode_t followed by a dev_t, with any padding zero'd out. The former is the type of the file (st_mode &
S_IFMT), the latter is the st_rdev field.
The options are as follows:
-c Create a db(3) database for compatibility with libc versions and statically linked programs from before NetBSD 6.0. The default name
Put the output databases in the named file.
/dev Device directory.
/var/run/dev.db Database file.
SEE ALSO ps(1), stat(2), db(3), devname(3), kvm_nlist(3), ttyname(3), kvm_mkdb(8)HISTORY
The dev_mkdb command appeared in 4.4BSD.
BSD June 1, 2012 BSD
I am reading a Sunsolve document covering moving /var and am confused by one step. What does this command do (in English):
Move into the existing /var directory and transfer all the data to /newvar
# cd /var
# tar cvf - . | (cd /newvar; tar xfBp -) (4 Replies)
need help with the df command....
If I do this: df -kh /var
Filesystem Size Used Avail Use% Mounted on
/dev/sda15 17G 5.8G 9.9G 38% /var
How can I display, in the same way, the usage of each directory inside the /var?
thanks for the help! (2 Replies)
I have some problem in my file system :
df -k result :
/dev/md/dsk/d3 3101839 2736380 303423 91% /var
it occupied around 2.7 gb
but when I tried command
du -sk /var
so /var only have around 800Mb , Do you know why there is many difference... (6 Replies)
I am working on a script to measure the read performance of a busybox environment. The logical choice is to use a command line like:
(time cp * /dev/null) 2> /tmp/howlong.txt
Ah, the rub is cp or /dev/null will only accept a single file at a time.
The result in the txt file is and... (1 Reply)
Hi, with this command:
cu -l /dev/ttyACM0 -s 9600 > name.txt
I put the output of the port in a txt
Is posible to do the same (or similar) in a var directly, inside a C program?
cu -l /dev/ttyACM0 -s 9600 > variable ?
I have trying this withs pipes, but i dont know how to... (6 Replies)
As I'm new here, please forgive me if any rule violation occurred.
I have a script like this:
# Author : Saptarshi
# Date : 18-Mar-2011
# Version : 1.0
Return_op=`sqlplus -s <<ENDOFSQL
WHENEVER SQLERROR EXIT 1
set ... (1 Reply)
i need to install a software into a zone, and this kind of software needs to have a file who is linked into /dev.
But it is not possible to create a link into /dev nor create a file into it.
-bash-3.00# ln -s /tmp/testfile /dev/
ln: cannot create /dev//testfile: Permission denied... (2 Replies)
I want to run a find command on the UNIX directory for all type -c and type -b files, then verify they are located in the default /dev directory.
Problem is I get such a huge list of files when I run the search, I think it would be easier if I simply did a search for all type -c and type -b... (6 Replies)
My var directory is showing near to 100% ? What are the files should i delete to make it less??
# bdf -i
Filesystem kbytes used avail %used iused ifree %iuse Mounted on
/dev/vg00/lvol3 1048576 107616 933616 10% 3342 29394 10% /... (10 Replies)
I'm having problem with /var directory which is keep increasing. Here's the output of bdf and du command
# uname -a
HP-UX rppmis1 B.11.11 U 9000/800 1153414645 unlimited-user license
# bdf /var
Filesystem kbytes used avail %used Mounted on
/dev/vg00/lvol8 ... (8 Replies)
Hello my friends,
I have a directory called
when I try to delete it, it tells me no such file or directory.
Then I tried to run this command:
It tells me the directory name, it is: log_old1\177
I tried to remove it using inode, using this... (4 Replies)
I need to install a new application on my linux server but needs to have a new directory e.g /opt/InCharge as this is the directory that the application would ask for during installation .This directory needs to be mounted
if df -h it should appear as mounted (9 Replies)