Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dev_mkdb(8) [netbsd man page]

DEV_MKDB(8)						    BSD System Manager's Manual 					       DEV_MKDB(8)

NAME
dev_mkdb -- create /dev database SYNOPSIS
dev_mkdb [-c] [-o database] [directory] DESCRIPTION
The dev_mkdb command creates a cdbr(3) database in ``/var/run/dev.cdb'' which contains the names of all of the character and block special files in the specified directory, using the file type and the st_rdev field as the key. If no directory is specified, the ``/dev'' directory is used. Keys are a structure containing a mode_t followed by a dev_t, with any padding zero'd out. The former is the type of the file (st_mode & S_IFMT), the latter is the st_rdev field. The options are as follows: -c Create a db(3) database for compatibility with libc versions and statically linked programs from before NetBSD 6.0. The default name is ``/var/run/dev.db''. -o database Put the output databases in the named file. FILES
/dev Device directory. /var/run/dev.db Database file. SEE ALSO
ps(1), stat(2), db(3), devname(3), kvm_nlist(3), ttyname(3), kvm_mkdb(8) HISTORY
The dev_mkdb command appeared in 4.4BSD. BSD
June 1, 2012 BSD

Check Out this Related Man Page

DEVNAME(3)						   BSD Library Functions Manual 						DEVNAME(3)

NAME
devname -- get device name LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <sys/stat.h> #include <stdlib.h> char * devname(dev_t dev, mode_t type); char * devname_r(dev_t dev, mode_t type, char *buf, int len); char * fdevname(int fd); char * fdevname_r(int fd, char *buf, int len); DESCRIPTION
The devname() function returns a pointer to the name of the block or character device in /dev with a device number of dev, and a file type matching the one encoded in type which must be one of S_IFBLK or S_IFCHR. To find the right name, devname() asks the kernel via the kern.devname sysctl. If it is unable to come up with a suitable name, it will format the information encapsulated in dev and type in a human-readable format. The fdevname() and fdevname_r() function obtains the device name directly from a file descriptor pointing to a character device. If it is unable to come up with a suitable name, these functions will return a NULL pointer. devname() and fdevname() return the name stored in a static buffer which will be overwritten on subsequent calls. devname_r() and fdevname_r() take a buffer and length as argument to avoid this problem. EXAMPLES
int fd; struct stat buf; char *name; fd = open("/dev/tun"); fstat(fd, &buf); printf("devname is /dev/%s ", devname(buf.st_rdev, S_IFCHR)); printf("fdevname is /dev/%s ", fdevname(fd)); SEE ALSO
stat(2) HISTORY
The devname() function appeared in 4.4BSD. The fdevname() function appeared in FreeBSD 8.0. BSD
February 22, 2005 BSD
Man Page

15 More Discussions You Might Find Interesting

1. Solaris

Sun Unix command clarification

I am reading a Sunsolve document covering moving /var and am confused by one step. What does this command do (in English): Move into the existing /var directory and transfer all the data to /newvar # cd /var # tar cvf - . | (cd /newvar; tar xfBp -) (4 Replies)
Discussion started by: FredSmith
4 Replies

2. Filesystems, Disks and Memory

df command

Hello All, need help with the df command.... If I do this: df -kh /var Filesystem Size Used Avail Use% Mounted on /dev/sda15 17G 5.8G 9.9G 38% /var How can I display, in the same way, the usage of each directory inside the /var? thanks for the help! (2 Replies)
Discussion started by: pmpx
2 Replies

3. UNIX for Dummies Questions & Answers

free some space in file system

dear all, I have some problem in my file system : df -k result : ... /dev/md/dsk/d3 3101839 2736380 303423 91% /var ... it occupied around 2.7 gb but when I tried command du -sk /var 813991 /var so /var only have around 800Mb , Do you know why there is many difference... (6 Replies)
Discussion started by: fu4d
6 Replies

4. AIX

/dev/hd9var full

/dev/hd9var 819200 1928 100% 12101 12% /var the filesystem is full my self being new to aix what do i do to create space (1 Reply)
Discussion started by: freeman
1 Replies

5. UNIX for Dummies Questions & Answers

cp output /dev/null results in not a directory

Hello, I am working on a script to measure the read performance of a busybox environment. The logical choice is to use a command line like: (time cp * /dev/null) 2> /tmp/howlong.txt Ah, the rub is cp or /dev/null will only accept a single file at a time. The result in the txt file is and... (1 Reply)
Discussion started by: stevesmo
1 Replies

6. Programming

Command output into a variable

Hi, with this command: cu -l /dev/ttyACM0 -s 9600 > name.txt I put the output of the port in a txt Is posible to do the same (or similar) in a var directly, inside a C program? cu -l /dev/ttyACM0 -s 9600 > variable ? I have trying this withs pipes, but i dont know how to... (6 Replies)
Discussion started by: daaran
6 Replies

7. UNIX for Dummies Questions & Answers

/dev/null 2>&1 Versus /dev/null 2>1

How are these two different? They both prevent output and error from being displayed. I don't see the use of the "&" echo "hello" > /dev/null 2>&1 echo "hello" > /dev/null 2>1 (3 Replies)
Discussion started by: glev2005
3 Replies

8. Programming

How to Format database output (DBMS_OUTPUT.PUT_LINE) in unix?

Dear All, As I'm new here, please forgive me if any rule violation occurred. I have a script like this: #! /bin/ksh # Author : Saptarshi # Date : 18-Mar-2011 # Version : 1.0 Return_op=`sqlplus -s <<ENDOFSQL db_user/db_pass@db_nm WHENEVER SQLERROR EXIT 1 set ... (1 Reply)
Discussion started by: saps19
1 Replies

9. Solaris

Create sym-link into /dev (zone)

Hi i need to install a software into a zone, and this kind of software needs to have a file who is linked into /dev. But it is not possible to create a link into /dev nor create a file into it. -bash-3.00# ln -s /tmp/testfile /dev/ ln: cannot create /dev//testfile: Permission denied... (2 Replies)
Discussion started by: beta17
2 Replies

10. Solaris

Modify /var/run.

Hello, I want to modify the /var/run fs from 86G to say 2G. How to go about it? Thanks. swap 64G 38K 64G 1% /var/run Regards. Edit/Delete Message (6 Replies)
Discussion started by: mahive
6 Replies

11. Shell Programming and Scripting

find command help.

I want to run a find command on the UNIX directory for all type -c and type -b files, then verify they are located in the default /dev directory. Problem is I get such a huge list of files when I run the search, I think it would be easier if I simply did a search for all type -c and type -b... (6 Replies)
Discussion started by: Lucisama
6 Replies

12. HP-UX

[Solved] /var directory in HP-UX is showing 95%?

Hi Everyone, My var directory is showing near to 100% ? What are the files should i delete to make it less?? Kindly suggest # bdf -i Filesystem kbytes used avail %used iused ifree %iuse Mounted on /dev/vg00/lvol3 1048576 107616 933616 10% 3342 29394 10% /... (10 Replies)
Discussion started by: yadvinder
10 Replies

13. HP-UX

Unidentified File on /var Directory

Hi All, I'm having problem with /var directory which is keep increasing. Here's the output of bdf and du command # uname -a HP-UX rppmis1 B.11.11 U 9000/800 1153414645 unlimited-user license # bdf /var Filesystem kbytes used avail %used Mounted on /dev/vg00/lvol8 ... (8 Replies)
Discussion started by: stu33
8 Replies

14. HP-UX

Directory can't remove!

Hello my friends, I have a directory called log_old when I try to delete it, it tells me no such file or directory. Then I tried to run this command: ls -lb It tells me the directory name, it is: log_old1\177 !! I tried to remove it using inode, using this... (4 Replies)
Discussion started by: Mohannad
4 Replies

15. UNIX for Dummies Questions & Answers

New mounted directory

Hello I need to install a new application on my linux server but needs to have a new directory e.g /opt/InCharge as this is the directory that the application would ask for during installation .This directory needs to be mounted if df -h it should appear as mounted (9 Replies)
Discussion started by: DOkuwa
9 Replies