|Linux & Unix Commands - Search Man Pages
DBSYM(8) BSD System Manager's Manual DBSYM(8)
dbsym -- copy kernel symbol table into db_symtab space
dbsym [-v] [-b bfdname] kernel
dbsym is used to copy the symbol table in a newly linked kernel into the db_symtab array (in
the data section) so that the ddb(4) kernel debugger can find the symbols. This program is
only used on systems for which the boot program does not load the symbol table into memory
with the kernel. The space for these symbols is reserved in the data segment using a config
The size of the db_symtab array (the value of SYMTAB_SPACE) must be at least as large as the
kernel symbol table. If insufficient space is reserved, dbsym will refuse to copy the sym-
To recognize kernel executable format, the -b flag specifies BFD name of kernel.
If the -v flag is given, dbsym will print out status information as it is copying the symbol
Note that debugging symbols are not useful to the ddb(4) kernel debugger, so to minimize the
size of the kernel, one should either compile the kernel without debugging symbols (no -g
flag) or use the strip(1) command to strip debugging symbols from the kernel before dbsym is
used to copy the symbol table. The command
strip -d netbsd
will strip out debugging symbols.
BSD November 9, 2001 BSD
All times are GMT -4. The time now is 11:53 AM.