|Linux & Unix Commands - Search Man Pages
RPC.BOOTPARAMD(8) BSD System Manager's Manual RPC.BOOTPARAMD(8)
bootparamd, rpc.bootparamd -- boot parameter server
bootparamd [-ds] [-i interface] [-r router] [-f file]
bootparamd is a server process that provides information to diskless clients necessary for
booting. It consults the file ``/etc/bootparams''. It should normally be started from
This version will allow the use of aliases on the hostname in the ``/etc/bootparams'' file.
The hostname returned in response to the booting client's whoami request will be the name
that appears in the config file, not the canonical name. In this way you can keep the
answer short enough so that machines that cannot handle long hostnames won't fail during
While parsing, if a line containing just ``+'' is found, and the YP subsystem is active, the
YP map bootparams will be searched immediately.
-d Display the debugging information. The daemon does not fork in this case.
Specify the interface to become the default router. bootparamd picks the first IPv4
address it finds on the system by default. With -i, you can control which interface
to be used to obtain the default router address. -r overrides -i.
-s Log the debugging information with syslog(3).
-r Set the default router (a hostname or IP-address). This defaults to the machine
running the server.
-f Specify the file to use as boot parameter file instead of ``/etc/bootparams''.
/etc/bootparams default configuration file
Originally written by Klas Heggemann <firstname.lastname@example.org>.
You may find the syslog messages too verbose.
It's not clear if the non-canonical hack mentioned above is a good idea.
BSD January 8, 1994 BSD
All times are GMT -4. The time now is 09:10 AM.