APM(8) BSD System Manager's Manual APM(8)
apm, zzz -- Advanced Power Management control program
apm [-abdlmsSvz] [-f sockname]
zzz [-Sz] [-f sockname]
The apm program communicates with the Advanced Power Management (APM) daemon, apmd(8), making requests of the current power status or placing
the system either into suspend or stand-by state. The apm tool is only installed on supported platforms.
With no flags, apm displays the current power management state in verbose form.
Available command-line flags are:
-z Put the system into suspend (deep sleep) mode.
-S Put the system into stand-by (light sleep) mode.
-l Display the estimated battery lifetime in percent.
-m Display the estimated battery lifetime in minutes.
-b Display the battery status: 0 means high, 1 means low, 2 means critical, 3 means charging, 4 means absent, and 255 means
-a Display the external charger (A/C status): 0 means disconnected, 1 means connected, 2 means backup power source, and 255 means
-s Display if power management is enabled.
-v Request more verbose description of the displayed states.
-f sockname Set the name of the socket via which to contact apmd(8) to sockname.
-d Do not communicate with the APM daemon; attempt instead to manipulate the APM control device directly.
The zzz variant of this command is an alternative for suspending the system. With no arguments, zzz places the system into suspend mode.
The command line flags serve the same purpose as for the apm variant of this command.
This command does not wait for positive confirmation that the requested mode has been entered; to do so would mean the command does not
return until the system resumes from its sleep state.
/var/run/apmdev is the default UNIX-domain socket used for communication with apmd(8). The -f flag may be used to specify an alternate
socket name. The protection modes on this socket govern which users may access the APM functions.
/dev/apmctl is the control device which is used when the -d flag is specified; it must be writable for the -d flag to work successfully.
/dev/apm is the status device used when the socket is not accessible; it must be readable to provide current APM status.
acpi(4), apm(4), apmd(8)
Intel Corporation and Microsoft Corporation, Advanced Power Management (APM) BIOS Interface Specification, Revision 1.2, February 1996.
The apm command appeared in NetBSD 1.3.
The APM specification first appeared in 1992. The last update to the standard was made in 1996 - the same year when it was superceded by the
ACPI 1.0 standard. Thereafter power management on IBM-compatible personal computers has relied on ACPI, implemented in NetBSD by the acpi(4)
subsystem. The acpi(4) provides an emulation layer for the legacy apm.
March 20, 2010 BSD
Check Out this Related Man Page
apmd - Advanced Power Management (APM) daemon
apmd [ -TVWciqv ] [ -P program ] [ -T seconds ] [ -c seconds ] [ -p percent ] [ -v level ] [ -w percent ]
apmd is an monitoring daemon for the Advanced Power Management (APM) subsystem. The APM subsystem consists of power-management hardware,
firmware usually referred to as the APM BIOS and a driver in the operating system kernel. The daemon can execute a program (usually a
shell script) when events are reported by the APM subsystem, and will log, via syslogd(8), certain changes in power status. When the
available battery power becomes very low it can alert the user.
When the APM subsystem notifies the daemon of a pending suspend or standby request, apmd will run a proxy program, log the event, sync(2)
data to the disk and then tell the APM subsystem to continue its operation.
Preparations for power management events are made mainly by the proxy program specified using the -P option. The proxy program is invoked
with one or two arguments:
start Invoked when the daemon starts.
stop Invoked when the daemon stops.
standby ( system | user )
Invoked when the APM subsystem reports that standby has been initiated. The second parameter indicates whether firmware ("system")
or software ("user") was the originator of the event.
The "standby" mode conserves power but leaves the machine able to respond almost immediately to user activity. Most laptops can't
stay in standby mode on battery power for more than a few hours or a day. Normally, nothing special needs to be done to prepare for
suspend ( system | user )
Invoked when the APM subsystem reports that suspension has been initiated. The second parameter indicates whether firmware ("sys-
tem") or software ("user") was the originator of the event.
The "suspend" mode aggressively conserves power. Usually this involves shutting off power to all devices except the CPU core and
memory, which are put into a very low power mode. Most laptops can stay suspended, using battery power alone, for several days.
("Hibernation" is a kind of super-suspend, where all that state is written to disk and the machine uses no power. Hibernation is
treated like suspension by the APM subsystem.)
Before suspending, PCMCIA devices may need to be disabled using cardctl(8), and some modular device drivers may need to be unloaded
if they have not been designed to support power management.
resume ( suspend | standby | critical )
Invoked when the APM subsystem reports that computer has resumed normal operation. The second parameter indicates the kind of event
from which the system is resuming. (A "critical" suspend is a suspension that the APM subsystem performs in an emergency. Some
kernels do not pass this event to user space. If apmd receives the event, it acknowledges the event and exits immediately without
logging or running the proxy program.)
When resuming, PCMCIA devices may need to be re-enabled using cardctl(8), and some modular drivers may need to be reloaded. Note
that in the case of a critical suspend, the system state may not have been completely saved.
Invoked when the APM subsystem reports a change in power status, such as a switch from mains to battery power.
Invoked when the APM subsystem reports that the charge of one or more batteries is low. A few minutes of battery power may remain.
Invoked when the APM subsystem reports some change in power management capabilities. It may have been caused by operation of a set-
up utility, or by the installation or removal of devices.
apmd emits various messages, most of which are self-explanatory. Battery status log entries contain three fields, separated by commas.
The first field indicates how full the battery is as a percentage of its capacity. The second field indicates whether the battery is
charging, not charging, or discharging. When possible, apmd adds in parentheses its estimate of the rate of charging or discharging. The
third field indicates how much time the battery can or could be used to power the computer. This information is provided by the APM sub-
system. When possible, apmd adds in parentheses its own estimate of the battery life (if discharging) or of the time required to charge
the battery fully (if charging).
-P program, --proxy program
Specifies the proxy program to execute when events are received. See above for information about the arguments supplied to this
-T [seconds] , --proxy-timeout [seconds]
Sets a time-out for the proxy. Without this option (or with this option and a negative argument) apmd waits indefinitely for the
proxy to finish. If the proxy enters an infinite loop or wait then the machine may appear to have crashed. If this option is given
a positive integer argument then apmd will wait only that many seconds for the proxy to finish, after which it will log a warning,
kill the proxy, and continue processing the event. The default is 30 seconds.
Prints the version of the apmd program.
In addition to logging low battery status (as determined either by the -w level or by the firmware) using syslog(2), apmd will,
given this option, also use wall(1) to alert all users. This is most useful if syslogd(8) is not set up to write ALERT messages to
all users. If both methods are used, more warnings will be made during the critical time period.
-c [seconds] , --check [seconds]
Controls how many seconds to wait for an event. Without this option (or with this option and a negative argument) apmd waits indef-
initely for an event. If this option is given a positive integer argument then apmd will wait only that many seconds before check-
ing the battery level and possibly sending out a warning, calling the proxy or making an entry in the log. The default is 30 sec-
Causes apmd to ignore a LOW BATTERY signal sent by the APM subsystem. Some firmware signals a low battery at the wrong time. Note
that LOW BATTERY events may still be generated by apmd itself based on the warning level.
-p percent, --percentage percent
Controls how often the battery status is logged. A new line is printed each time the battery content changes by percent_change if
logging is enabled. The default is 5. Use a value greater than 100 to disable periodic logging of the battery level.
Causes apmd not to generate a warning when a LOW BATTERY signal is received from the APM subsystem. The firmware on some machines
produces an audible warning when power is about to be used up, so an extra warning may not be needed.
-v [level] , --verbose [level]
The daemon can generate messages of varying degrees of unimportance. Each message is assigned one of the priority levels defined
for the syslogd(8) subsystem, ranging from 0 (EMERG, least unimportant) to 7 (DEBUG, most unimportant). This option sets the
threshold level above which messages are suppressed. Without an argument it increments the threshold by 1, thus making apmd more
verbose. The default is 5 (NOTICE).
-w percent, --warn percent
When the battery is not being charged and the battery content falls below the specified percent of capacity, and no such event has
yet occurred in the current discharge cycle, apmd will log a warning at the ALERT log level to syslog(2) and generate a LOW BATTERY
event. If the -W or --wall option was given, the daemon will also use wall(1) to alert all users of impending doom. The default
warning level is 10. Use a negative value to disable this feature.
Causes apmd to print a brief command summary and exit.
This daemon supports all APM events described in the APM BIOS specification version 1.2; however it fails to support some of the advanced
features of APM 1.2, such as reporting the conditions of multiple batteries. (Multiple batteries are currently treated as if they were
just one large one.)
Estimates of charge and discharge rates and times can be very inaccurate.
There is no interaction yet with ACPI support as found in newer PC hardware.
Device through which apmd communicates with the Linux APM driver.
APM driver status information
Proxy program that is run if none is specified.
Proxy program that is run if none is specified. (Debian)
This program was written by Rik Faith (firstname.lastname@example.org) and may be freely distributed under the terms of the GNU General Public License.
There is ABSOLUTELY NO WARRANTY for this program. The current maintainer is Avery Pennarun (email@example.com).
apm(1), xapm(1), cardctl(8), syslogd(8).
January 2004 APMD(8)