Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

debhelper-obsolete-compat(7) [netbsd man page]

debhelper(7)							     Debhelper							      debhelper(7)

NAME
debhelper-obsolete-compat - List of no longer supported compat levels SYNOPSIS
This document contains the upgrade guidelines from all compat levels which are no longer supported. Accordingly it is mostly for historical purposes and to assist people upgrading from a non-supported compat level to a supported level. For upgrades from supported compat levels, please see debhelper(7). UPGRADE LIST FOR COMPAT LEVELS
The following is the list of now obsolete compat levels and their changes. v1 This is the original debhelper compatibility level, and so it is the default one. In this mode, debhelper will use debian/tmp as the package tree directory for the first binary package listed in the control file, while using debian/package for all other packages listed in the control file. This mode is deprecated. v2 In this mode, debhelper will consistently use debian/package as the package tree directory for every package that is built. This mode is deprecated. v3 This mode works like v2, with the following additions: - Debhelper config files support globbing via * and ?, when appropriate. To turn this off and use those characters raw, just prefix with a backslash. - dh_makeshlibs makes the postinst and postrm scripts call ldconfig. - Every file in etc/ is automatically flagged as a conffile by dh_installdeb. This mode is deprecated. v4 Changes from v3 are: - dh_makeshlibs -V will not include the Debian part of the version number in the generated dependency line in the shlibs file. - You are encouraged to put the new ${misc:Depends} into debian/control to supplement the ${shlibs:Depends} field. - dh_fixperms will make all files in bin/ directories and in etc/init.d executable. - dh_link will correct existing links to conform with policy. This mode is deprecated. v5 This is the lowest supported compatibility level. Changes from v4 are: - Comments are ignored in debhelper config files. - dh_strip --dbg-package now specifies the name of a package to put debugging symbols in, not the packages to take the symbols from. - dh_installdocs skips installing empty files. - dh_install errors out if wildcards expand to nothing. SEE ALSO
debhelper(7) AUTHORS
Niels Thykier <niels@thykier.net> Joey Hess 11.1.6ubuntu2 2018-05-10 debhelper(7)

Check Out this Related Man Page

DH_INSTALLDEB(1)						     Debhelper							  DH_INSTALLDEB(1)

NAME
dh_installdeb - install files into the DEBIAN directory SYNOPSIS
dh_installdeb [debhelperoptions] DESCRIPTION
dh_installdeb is a debhelper program that is responsible for installing files into the DEBIAN directories in package build directories with the correct permissions. FILES
package.postinst package.preinst package.postrm package.prerm These maintainer scripts are installed into the DEBIAN directory. Inside the scripts, the token #DEBHELPER# is replaced with shell script snippets generated by other debhelper commands. package.triggers package.shlibs These control files are installed into the DEBIAN directory. Note that package.shlibs is only installed in compat level 9 and earlier. In compat 10, please use dh_makeshlibs(1). package.conffiles This control file will be installed into the DEBIAN directory. In v3 compatibility mode and higher, all files in the etc/ directory in a package will automatically be flagged as conffiles by this program, so there is no need to list them manually here. package.maintscript Lines in this file correspond to dpkg-maintscript-helper(1) commands and parameters. However, the "maint-script-parameters" should not be included as debhelper will add those automatically. Example: # Correct rm_conffile /etc/obsolete.conf 0.2~ foo # INCORRECT rm_conffile /etc/obsolete.conf 0.2~ foo -- "$@" In compat 10 or later, any shell metacharacters will be escaped, so arbitrary shell code cannot be inserted here. For example, a line such as "mv_conffile /etc/oldconffile /etc/newconffile" will insert maintainer script snippets into all maintainer scripts sufficient to move that conffile. It was also the intention to escape shell metacharacters in previous compat levels. However, it did not work properly and as such it was possible to embed arbitrary shell code in earlier compat levels. The dh_installdeb tool will do some basic validation of some of the commands listed in this file to catch common mistakes. The validation is enabled as a warning since compat 10 and as a hard error in compat 12. SEE ALSO
debhelper(7) This program is a part of debhelper. AUTHOR
Joey Hess <joeyh@debian.org> 11.1.6ubuntu2 2018-05-10 DH_INSTALLDEB(1)
Man Page