C(7) BSD Miscellaneous Information Manual C(7)
c, c78, c89, c90, c99 -- The C programming language
C is a general purpose programming language, which has a strong connection with the UNIX
operating system and its derivatives, since the vast majority of those systems were written
in the C language. The C language contains some basic ideas from the BCPL language through
the B language written by Ken Thompson in 1970 for the DEC PDP-7 machines. The development
of the UNIX operating system was started on a PDP-7 machine in assembly language, but this
choice made it very difficult to port the existing code to other systems.
In 1972 Dennis M. Ritchie worked out the C programming language for further development of
the UNIX operating system. The idea was to implement only the C compiler for different
platforms, and implement most parts of the operating system in the new programming language
to simplify the portability between different architectures. It follows that C is very well
adapted for (but not limited to) writing operating systems and low-level applications.
The C language did not have a specification or standardized version for a long time. It
went through a lot of changes and improvements for ages. In 1978, Brian W. Kernighan and
Dennis M. Ritchie published the first book about C under the title ``The C Programming
Language''. We can think of this book as the first specification of the language. This
version is often referred to as ``K&R C'' after the names of the authors. Sometimes it is
referred to as C78, as well, after the publishing year of the first edition of the book.
It is important to notice that the instruction set of the language is limited to the most
fundamental elements for simplicity. Handling of the standard I/O and similar common func-
tions are implemented in the libraries shipped with the compiler. As these functions are
also widely used, it was demanded to include into the description what requisites the
library should conform to, not just strictly the language itself. Accordingly, the afore-
mentioned standards cover the library elements, as well. The elements of this standard
library are still not enough for more complicated tasks. In this case the provided system
calls of the given operating system can be used. To not lose the portability by using these
system calls, the POSIX (Portable Operating System Interface (for Unix)) standard evolved.
It describes what functions should be available to keep portability. Note, that POSIX is
not a C standard, but an operating system standard and thus is beyond the scope of this man-
ual. The standards discussed below are all C standards and only cover the C programming
language and the accompanying library.
After the publication of the book mentioned before, the American National Standards Insti-
tute (ANSI) started to work on standardizing the language, and in 1989 they announced ANSI
X3.159-1989. It is usually referred to as ANSI C or C89. The main difference in this stan-
dard were the function prototypes, which was a new way of declaring functions. With the
old-style function declarations, the compiler was unable to check the sanity of the actual
parameters of a function call. The old syntax was highly error-prone because incompatible
parameters were hard to detect in the program code and the problem only showed up at run-
In 1990, the International Organization for Standardization (ISO) adopted the ANSI standard
as ISO/IEC 9899:1990. This is also referred to as ISO C or C90. It only contains negligi-
ble minor modifications against ANSI C, so the two standards are often considered to be
fully equivalent. This was a very important milestone in the history of the C language, but
the development of the language did not stop.
The ISO C standard was later extended with an amendment as ISO/IEC 9899 AM1 in 1995. This
contained, for example, the wide-character support in wchar.h and wctype.h. Two corrigenda
were also published: Technical Corrigendum 1 as ISO/IEC 9899 TCOR1 in 1995 and Technical
Corrigendum 2 as ISO/IEC 9899 TCOR2 in 1996. The continuous development and growth made it
necessary to work out a new standard, which contains the new features and fixes the known
defects and deficiencies of the language. As a result, ISO/IEC 9899:1999 was born in 1999.
Similarly to the other standards, this is referred to after the publication year as C99.
The improvements include the following:
o Inline functions.
o Support for variable length arrays.
o New high-precision integer type named long long int, and other integer types
described in stdint(3) and inttypes(3).
o New boolean data type; see stdbool(3).
o One line comments taken from the C++ language.
o Some new preprocessor features.
o A predefined identifier __func__ and a restrict type qualifier.
o New variables can be declared anywhere, not just in the beginning of the program
or program blocks.
o No implicit int type.
Since then no new standards have been published, but the C language is still evolving. New
and useful features have been showing up in the most famous C compiler: GNU C (gcc(1)).
Most of the UNIX-like operating systems use GNU C as a system compiler, but the various
extensions of GNU C, such as attribute(3) or typeof(3), should not be considered standard
c89(1), c99(1), cc(1), cdefs(3)
Brian W. Kernighan and Dennis M. Ritchie, The C Programming Language, Prentice Hall, Second
Edition, 40th printing, 1988.
ISO/IEC, 9899:1990, Programming languages -- C.
ISO/IEC, 9899 AM1.
ISO/IEC, 9899 TCOR1, Programming languages -- C, Technical Corrigendum 1.
ISO/IEC, 9899 TCOR2, Programming languages -- C, Technical Corrigendum 2.
ISO/IEC, 9899:1999, Programming languages -- C.
ISO/IEC, 9899:1999 TCOR1, Programming languages -- C, Technical Corrigendum 1.
ISO/IEC, 9899:1999 TCOR2, Programming languages -- C, Technical Corrigendum 2.
ISO/IEC, 9899:1999 TCOR3, Programming languages -- C, Technical Corrigendum 3.
This manual page first appeared in FreeBSD 9.0 and NetBSD 6.0.
This manual page was written by Gabor Kovesdan <gabor@FreeBSD.org>.
BSD March 30, 2011 BSD