|Linux & Unix Commands - Search Man Pages
WEEKLY(5) BSD File Formats Manual WEEKLY(5)
weekly, weekly.conf -- weekly maintenance
The /etc/weekly script is run, by default, every Saturday morning on a NetBSD system. The
/etc/weekly.conf file specifies which of the standard weekly services are performed.
The variables described below can be set to ``YES'' or ``NO'' in the /etc/weekly.conf file.
The default settings are in the /etc/defaults/weekly.conf file. (Note that you should never
edit /etc/defaults/weekly.conf directly, as it is often replaced during system upgrades.)
rebuild_locatedb This rebuilds the locate(1) database, /var/db/locate.database, which must
also exist, in order to be rebuilt.
rebuild_mandb This rebuilds the apropos(1) database /var/db/man.db, using makemandb(8)
with the -f option.
rebuild_whatisdb This rebuilds the whatis(1) database(s). Note that NetBSD provides a
default whatis.db for the system manual pages and this may not be needed.
(Adjust your /etc/man.conf as necessary; see man.conf(5) for details.)
/etc/weekly weekly maintenance script
/etc/weekly.conf weekly maintenance configuration
/etc/weekly.local local site additions to /etc/weekly
The /etc/weekly script first appeared in 4.3BSD. The /etc/weekly.conf configuration file
appeared in NetBSD 1.3.
BSD March 6, 2012 BSD
All times are GMT -4. The time now is 03:44 PM.