SERVICES(5) BSD File Formats Manual SERVICES(5)NAME
services -- service name data base
The services file contains information regarding the known services available in the DARPA Internet. For each service a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The port number and protocol name are considered a single item; a slash
(``/'') is used to separate the port and protocol (e.g. ``512/tcp''). A hash (``#'') indicates the beginning of a comment; subsequent char-
acters up to the end of the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field delimiter, newline, or comment character.
The database in /var/db/services.db needs to be updated with services_mkdb(8) after changes to the services file have been applied.
/etc/services The services file resides in /etc.
SEE ALSO getservent(3), services_mkdb(8)HISTORY
The services file format appeared in 4.2BSD.
A name server should be used instead of a static file.
BSD June 19, 2007 BSD
Check Out this Related Man Page
services(4) File Formats services(4)NAME
services - Internet services and aliases
The services file is a local source of information regarding each service available through the Internet. The services file can be used in
conjunction with or instead of other services sources, including the NIS maps "services.byname" and the NIS+ table "services." Programs
use the getservbyname(3SOCKET) routines to access this information.
The services file contains an entry for each service. Each entry has the form:
service-name port/protocol aliases
service-name This is the official Internet service name.
port/protocol This field is composed of the port number and protocol through which the service is provided, for instance,
aliases This is a list of alternate names by which the service might be requested.
Fields can be separated by any number of SPACE and/or TAB characters. A number sign (#) indicates the beginning of a comment; any charac-
ters that follow the comment character up to the end of the line are not interpreted by routines which search the file.
Service names may contain any printable character other than a field delimiter, a NEWLINE, or a comment character.
Any changes to a port assignment do not affect the actual port registration of the service.
/etc/nsswitch.conf configuration file for name-service switch
SEE ALSO getservbyname(3SOCKET), inetd.conf(4), nsswitch.conf(4)NOTES
/etc/inet/services is the official SVR4 name of the services file. The symbolic link /etc/services exists for BSD compatibility.
SunOS 5.10 12 Oct 2000 services(4)
I will want to disable all the ports not needed in my UNIX.
If I put a # sign at the beginning of the line of the port name I want to disable in /etc/services.... that's all????? Or I need to do anything else to disable a port???? (1 Reply)
What are all the services/daemons we use in NFS configuration?
I know that nfs,portmap,nfslock the the services we use.But I am not sure that which service wil do what job? Is there any other services running for NFS?
What services are running on server side and what services are running in... (4 Replies)
We currently experiencing a problem on our Unix server Sco 5.07 , whereby
the tcp services stops on it own and even if we restart the services manually the services still does not come up,We loose the printer and pc connections to the server we then need to restart the Unix server in... (1 Reply)
Can anyone help me by telling how to open port 161 in solaris 10? I have added it in /etc/services but it is not working. I checked by telneting but I could not connect to that server on the port 161. I am trying to communicate using snmp services. (6 Replies)
I did search on the subject on services in linux and they do explain how to find what are the services that loaded when the linux boot.
however I have not find how to detect what services run right now.
I would like to now that and how to kill services.
Thanks. (3 Replies)
In my AIX 5.3 box I already have the below entry:
#cat /etc/services | grep -i 3602
infiniswitchcl 3602/tcp # InfiniSwitch Mgr Client
infiniswitchcl 3602/udp # InfiniSwitch Mgr Client
Now I got an requirement to add the below entry in the same port... (6 Replies)
I had a doubt if any services need to be restarted if port no in /etc/services in an RHEL setup is changed. For eg, the port no of 443 for SSL may need to be changed.
I hope my query is clear whether any services need to be restarted if port no in /etc/services is changed.
Please revert with... (10 Replies)
I would like to know wheather it is possible to enable same services on another Linux Box, which are enabled on First Linux Server.
Server A having some services enabled, I want same kind of services enabled on Server B using single command / using chkconfig command, instead... (4 Replies)
OK HPUX masters I need help. I have a HPUX 11.23 server that I am using as a Ignite server that services two HPUX services for backups only. The other day I noticed that our Make Net Recoveries were failing. Upon attempting to login to the server SSH and could not I then tried to ping and could... (6 Replies)
I got the service status through nc on remote network but 2 services doesn't have port number.how to get the other 2 services status with out port number .pls provide the solution to me.
I need to develop with is in a script (2 Replies)