PROTOCOLS(5) BSD File Formats Manual PROTOCOLS(5)NAME
protocols -- protocol name data base
The protocols file contains information regarding the known protocols used in the DARPA Internet. For each protocol a single line should be
present with the following information:
official protocol name
Items are separated by any number of blanks and/or tab characters. A hash (``#'') indicates the beginning of a comment; characters up to the
end of the line are not interpreted by routines which search the file.
Protocol names may contain any printable character other than a field delimiter, newline, or comment character.
/etc/protocols The protocols file resides in /etc.
SEE ALSO getprotoent(3)HISTORY
The protocols file format appeared in 4.2BSD.
A name server should be used instead of a static file.
BSD June 5, 1993 BSD
Check Out this Related Man Page
protocols(4) File Formats protocols(4)NAME
protocols - protocol name database
The protocols file is a local source of information regarding the known protocols used in the DARPA Internet. The protocols file can be
used in conjunction with or instead of other protocols sources, including the NIS maps ``protcols.byname'' and "protocols.bynumber" and the
NIS+ table ``protocols''. Programs use the getprotobyname(3SOCKET) routine to access this information.
The protocols file has one line for each protocol. The line has the following format:
official-protocol-name protocol-number aliases
Items are separated by any number of blanks and/or TAB characters. A `#' indicates the beginning of a comment; characters up to the end of
the line are not interpreted by routines which search the file. Protocol names may contain any printable character other than a field
delimiter, NEWLINE, or comment character.
Example 1 A Sample Database
The following is a sample database:
# Internet (IP) protocols
ip 0 IP # internet protocol, pseudo protocol number
icmp 1 ICMP # internet control message protocol
ggp 3 GGP # gateway-gateway protocol
tcp 6 TCP # transmission control protocol
egp 8 EGP # exterior gateway protocol
pup 12 PUP # PARC universal packet protocol
udp 17 UDP # user datagram protocol
# Internet (IPv6) extension headers
hopopt 0 HOPOPT # Hop-by-hop options for IPv6
ipv6 41 IPv6 # IPv6 in IP encapsulation
ipv6-route 43 IPv6-Route # Routing header for IPv6
ipv6-frag 44 IPv6-Frag # Fragment header for IPv6
esp 50 ESP # Encap Security Payload for IPv6
ah 51 AH # Authentication Header for IPv6
ipv6-icmp 58 IPv6-ICMP # IPv6 internet control message protocol
ipv6-nonxt 59 IPv6-NoNxt # No next header extension header for IPv6
ipv6-opts 60 IPv6-Opts # Destination Options for IPv6
/etc/nsswitch.conf configuration file for name-service switch
SEE ALSO getprotobyname(3SOCKET), nsswitch.conf(4)NOTES
/etc/inet/protocols is the official SVR4 name of the protocols file. The symbolic link /etc/protocols exists for BSD compatibility.
SunOS 5.11 13 Jun 2002 protocols(4)
we r using cisco 7206 rtrs as our G/W rtrs the probs we r facing is we r not able to connect two G/Ws from different Service providers.what will be the reason for this problem ? whats the solution? did anybody faced the same probs if so pls help us to solve this probs.
Regds n... (2 Replies)
What protocol would be the best to use on a network with nt and unix servers and windows me clients?
Can SMB protocol be used to implement large networks?
What protocol can be used to make remote file systems appear as if they are local?
Quite a few questions I know, any help would be... (1 Reply)
Hi everyone, I would like to allow multi users to access P2P networks, so I wonder if there's a way to tracking these kind of protocols with netfilter, and also compatibility with nat, like the module conntrack_ftp seems to do with the FTP protocol.
Thanks guys. (0 Replies)
I have a question about routing in MANET using Dynamic Source Routing protocol.
IN RFC4728 (DSR) in section "IP fields" of RREP (Route Reply) packet we have this:
I read in several books and also in rfc4728 that: when a source node (node that initiate route discovery process)... (1 Reply)
planning to secure AIX sever by disabling insecure protocols/cipher suites; got the below requirements from secuirty team.
1.configure the server to disable support for DES and IDEA cipher suites
2.disable insecure TLS/SSL protocol support
Configure the server to... (4 Replies)