PKG_SUMMARY(5) BSD File Formats Manual PKG_SUMMARY(5)
pkg_summary -- summary of binary package repository
The file pkg_summary contains information about each package in a binary package repository
as a list of variable-value pairs. The variables describing different packages are sepa-
rated by one empty line. Each line has the format VARIABLE=VALUE. If the value consists of
more than one line, each line is prefixed with VARIABLE=. Multi-line variables are guaran-
teed to be in consecutive lines.
The following variables are used:
(required) The date and time when the package was built.
(required) A list of categories which this package fits in, separated by space.
(required) A one-line description of the package.
(optional) A list of dewey patterns of packages the package conflicts with, one per
line. If missing, this package has no conflicts.
(optional) A list of dewey patterns of packages the package depends on, one per
line. If missing, this package has no dependencies.
(required) A more detailed description of the package.
(optional) A checksum type supported by digest(1) and checksum separated by space
(optional) The name of the binary package file. If not given, PKGNAME.tgz can be
(optional) The size of the binary package file, in bytes.
(optional) A URL where more information about the package can be found.
(optional) The type of license this package is distributed under. If empty or miss-
ing, it is OSI-approved.
(required) The architecture on which the package was compiled.
OPSYS (required) The operating system on which the package was compiled.
(required) The version of the operating system on which the package was compiled.
(optional) Any options selected to compile this package. If missing, the package
does not support options.
(required) The name of the package.
(required) The path of the package directory within pkgsrc.
(required) The version of the package tools used to create the package.
(optional) The previous path of the package directory within pkgsrc when a package
was moved. (See SUPERSEDES below for a renamed package.)
(optional) A list of shared libraries provided by the package, including major ver-
sion number, one per line. If missing, this package does not provide shared
(optional) A list of shared libraries needed by the package, including major version
number, one per line. If missing, this package does not require shared libraries.
(required) The size of the package when installed, in bytes.
(optional) A list of dewey patterns of previous packages this package replaces, one
per line. This is used for package renaming.
The pkg_summary file can be generated using the pkg_info(1) -X option. For example, the
following will list this data for all installed packages:
pkg_info -X -a
The pkg_summary format was first officially documented in April 2006.
BSD April 11, 2009 BSD