NICKNAMES(5) BSD File Formats Manual NICKNAMES(5)NAME
nicknames -- map nickname translation file for NIS (YP)
The ypcat(1), ypmatch(1), and ypwhich(1) commands reference NIS (YP) maps as specified by the user. Occasionally it is desirable to use a
shorthand reference for a longer map name, hence the nicknames file, kept in ``/var/yp/nicknames.''
The format of the file is
one pair per line. The default installed nickname map is as follows:
A blank or incomplete nicknames file will affect any scripts which use nicknames for map lookup, whereas if the file is simply missing, the
default compiled-in list will be used.
SEE ALSO ypcat(1), ypmatch(1), ypwhich(1)HISTORY
The nicknames file first appeared in Solaris 2.4.
BSD August 28, 2003 BSD
Check Out this Related Man Page
YPWHICH(1) BSD General Commands Manual YPWHICH(1)NAME
ypwhich -- return hostname of NIS server of map master
ypwhich [-T] [-d domain] [[-h] host]
ypwhich [-fTt] [-d domain] [-h host] -m [mname]
ypwhich tells which NIS server supplies NIS services to a client, or which is the master for a map. If invoked without arguments, it gives
the NIS server for the local machine. If host is specified, that machine is queried to find out which NIS server it is using.
The options are as follows:
-d domain Specify a domain other than the default domain.
-f When used in conjunction with -m, force ypwhich to query host directly, without using the local copy of ypbind(8).
-h host Specify a host other than localhost to query for information.
-m [mname] Find the master NIS server for the named map. mname can be a map name or nickname. If mname is omitted, ypwhich will produce a
list of available maps.
-T Use TCP protocol instead of UDP.
-t Inhibit translation of map nicknames to their corresponding map names.
-x Display the map nickname table, found in /var/yp/nicknames. A built-in default translation table is used if /var/yp/nicknames
does not exist (see nicknames(5) for details).
ypwhich exits with a non-zero exit code if -m is used, and there was a problem in determining the map's master.
SEE ALSO domainname(1), ypcat(1), ypmatch(1), nicknames(5), nis(8), ypbind(8), yppoll(8), ypset(8)AUTHORS
Charles D. Cranor
BSD January 24, 2008 BSD
I have a text file that I want a script to parse and grab only the relavent stuff.
No idea where to start..
This is the text file.212 0.00000 ? -> (multicast) ETHER Type=2000 (Unknown), size = 344 bytes
0: 0100 0ccc cccc 000b 5f95 0fbe 014a aaaa ........_....J..... (7 Replies)
I have a list of ids and a master list. I need to display entries from the master list matching ids in the first list. The master list is space delimited, id is 1st field.
$ cat id_list
$ cat master_list
1 one detail1 detail2
2 two detail1 avg1 detail2 avg2
... etc ...
... (3 Replies)
I know that forward slash and backslash are "whack" and "backwhack," and I know that a pound-sign or number sign is "crunch" and an exclamation point, "bang." What I would like to know is whether or not there's a popular nickname for the dollar sign. I call it "cash," but that may just be Yank... (6 Replies)
I am new to Shell Scripting, and I need to create nicknames for 600 tables in db2. I have the file names in a text file and i have to pass these table names to a shell script create nicknames in db2. Can some one please help me in this regard. (1 Reply)
Hello - I have a script which creates a NIS user on Solaris machine. Before creating the user I check if the user being created laready exists or not using ypmatch and use $? to get the exit code. If a user exists, I get 0, works fine. However when the user is not found, the shell scripts exits by... (1 Reply)