|Linux & Unix Commands - Search Man Pages
IFALIASES(5) BSD File Formats Manual IFALIASES(5)
ifaliases -- interface aliases file
The ifaliases file specifies the additional addresses (aliases) that each interface has.
ifaliases is processed by /etc/rc.d/network at system boot time.
Each line of the file is of the form:
address interface [netmask]
The address is a network address of the alias. This must be a number, or must be in
/etc/hosts, since the nameserver is not running at this point.
The interface is the network interface the alias will be configured on.
The netmask is the netmask of the alias' network address. Although this is optional, omit-
ting the netmask is discouraged. Omission results in the use of the classful netmask asso-
ciated with address.
The ifaliases file appeared in NetBSD 1.2.
ifaliases assumes IPv4, and does not support other protocol families. Please check
rc.conf(5) for alternatives like /etc/ifconfig.xxN.
BSD November 17, 2000 BSD
All times are GMT -4. The time now is 12:07 PM.