GPIO.CONF(5) BSD File Formats Manual GPIO.CONF(5)NAME
gpio.conf -- GPIO config file
DESCRIPTION
The gpio.conf file is read by the gpio rc.d script during system start-up and shutdown, and is intended for configuring GPIO pins.
FILE FORMAT
Lines starting with a hash ('#') and empty lines are ignored. All other lines are passed to gpioctl(8).
FILES
/etc/gpio.conf The gpio.conf configuration file resides in /etc.
/etc/rc.d/gpio rc.d(8) script that parses gpio.conf.
EXAMPLES
In this example, if the /etc/gpio.conf config file is present pin 1 of /dev/gpio0 is set as output and named "error_led".
# Program pin 1 of /dev/gpio0 as output and name it "error_led"
gpio0 1 set out error_led
SEE ALSO gpioctl(8), rc(8)BSD August 1, 2009 BSD
Check Out this Related Man Page
GPIOPWM(4) BSD Kernel Interfaces Manual GPIOPWM(4)NAME
gpiopwm -- support for pulsing GPIO pins in software
SYNOPSIS
gpiopwm* at gpio? offset ? mask 1
gpiopwm* at gpio?
DESCRIPTION
The gpiopwm driver allows for pulsing GPIO pins in software using the callout(9) facility. The pulse frequency and duty cycle are specified
indirectly by setting an ``on'' and ``off'' period, in ticks. Both values are accessible as sysctl(3) variables.
SYSCTL VARIABLES
The following sysctl(3) variables are used to define the pulsing:
hw.gpiopwmN.off
Define the ``off'' period in ticks.
hw.gpiopwmN.on
Define the ``on'' period in ticks.
Only when both the ``on'' and the ``off'' period are set to values higher than zero pulsing will start. To stop the pulsing, set either
value to zero.
EXAMPLES
To pulse a pin on a machine with 100 ticks/second with a frequency of 1Hz and a duty cycle of 20%, the ``on'' period must be set to 20 and
the ``off'' period must be set to 80. The following example will pulse the error LED of a Soekris net4801 with a frequency of 1 Hz and a
duty cycle of 20%:
# gpioctl gpio0 20 set pp
# gpioctl gpio0 attach gpiopwm 20 1
# sysctl -w hw.gpiopwm0.off=80
# sysctl -w hw.gpiopwm0.on=20
SEE ALSO gpio(4), intro(4), gpioctl(8), sysctl(8)HISTORY
The gpiopwm driver first appeared in NetBSD 6.0.
AUTHORS
The gpiopwm driver was written by Marc Balmer <marc@msys.ch>.
BSD November 13, 2011 BSD
Introduction
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
996 mmmmmmm
996 xxxxxxxxxxxxx
99600 ssssssssss
9964 fffffffffffff
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
99600 ssssssssss
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
main()
{
malloc(1gb)
return(0)
}
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
Hey All,
Quick question...
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
Hi,
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)