Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ethers(5) [netbsd man page]

ETHERS(5)						      BSD File Formats Manual							 ETHERS(5)

NAME
ethers -- Ethernet host name data base DESCRIPTION
The ethers file maps Ethernet MAC addresses to host names. Lines consist of an address and a host name, separated by any number of blanks and/or tab characters. A '#' character indicates the beginning of a comment; characters up to the end of the line are not interpreted by routines which search the file. Each line in ethers has the format: ethernet-MAC-address hostname-or-IP Ethernet MAC addresses are expressed as six hexadecimal numbers separated by colons, e.g. "08:00:20:00:5a:bc". The functions described in ethers(3) and ether_aton(3) can read and produce this format. The traditional use of ethers involved using hostnames for the second argument. This may not be suitable for machines that don't have a com- mon MAC address for all interfaces (i.e., just about every non Sun machine). There should be no problem in using an IP address as the second field if you wish to differentiate between different interfaces on a system. FILES
/etc/ethers The ethers file resides in /etc. SEE ALSO
ethers(3) HISTORY
The ethers file format was adopted from SunOS and appeared in NetBSD 1.0. BUGS
A name server should be used instead of a static file. BSD
November 7, 2000 BSD

Check Out this Related Man Page

ETHERS(3)						   BSD Library Functions Manual 						 ETHERS(3)

NAME
ether_ntoa, ether_aton, ether_ntohost, ether_hostton, ether_line, -- get ethers entry LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <sys/types.h> #include <sys/socket.h> #include <net/if.h> #include <net/if_ether.h> char * ether_ntoa(const struct ether_addr *e); struct ether_addr * ether_aton(const char *s); int ether_ntohost(char *hostname, const struct ether_addr *e); int ether_hostton(const char *hostname, struct ether_addr *e); int ether_line(const char *line, struct ether_addr *e, char *hostname); DESCRIPTION
Ethernet addresses are represented by the following structure: struct ether_addr { u_char ether_addr_octet[6]; }; The ether_ntoa() function converts this structure into an ASCII string of the form ``xx:xx:xx:xx:xx:xx'', consisting of 6 hexadecimal numbers separated by colons. It returns a pointer to a static buffer that is reused for each call. The ether_aton() converts an ASCII string of the same form and to a structure containing the 6 octets of the address. It returns a pointer to a static structure that is reused for each call. The ether_ntohost() and ether_hostton() functions interrogate the data base mapping host names to Ethernet addresses, /etc/ethers. The ether_ntohost() function looks up the given Ethernet address and writes the associated host name into the character buffer passed. The ether_hostton() function looks up the given host name and writes the associated Ethernet address into the structure passed. Both functions return zero if they find the requested host name or address, and -1 if not. Each call reads /etc/ethers from the beginning; if a + appears alone on a line in the file, then ether_hostton() will consult the ethers.byname YP map, and ether_ntohost() will consult the ethers.byaddr YP map. The ether_line() function parses a line from the /etc/ethers file and fills in the passed ``struct ether_addr'' and character buffer with the Ethernet address and host name on the line. It returns zero if the line was successfully parsed and -1 if not. The hostname buffer for ether_line() and ether_ntohost() should be at least MAXHOSTNAMELEN + 1 characters long, to prevent a buffer overflow during parsing. FILES
/etc/ethers SEE ALSO
ethers(5) HISTORY
The ether_ntoa(), ether_aton(), ether_ntohost(), ether_hostton(), and ether_line() functions were adopted from SunOS and appeared in NetBSD 1.0. BUGS
The data space used by these functions is static; if future use requires the data, it should be copied before any subsequent calls to these functions overwrite it. BSD
November 2, 1997 BSD
Man Page