|Linux & Unix Commands - Search Man Pages
XBD(4) BSD Kernel Interfaces Manual XBD(4)
xbd -- Xen frontend paravirtualized block device interface
xbd* at xenbus?
The xbd interface forms the frontend part of the paravirtualized drivers used by Xen guest
domains to have a block device interface.
From a guest point of view, xbd is similar to a hard disk, and can be treated in the very
same way regarding partitioning, file systems creation and usage, and mounting. By default,
a NetBSD guest domain will assume that ``xbd0a'' serves as the root file system.
When the host is NetBSD, the xbd interface is backed by a xbdback(4) interface. In the Xen-
Store, xbd and xbdback are identified by ``vbd'' (virtual block device) entries.
xbd%d: using event channel %d Specifies the event channel used by this xbd interface.
xbd%d: %s MB, %d bytes/sect x %u sectors Gives the total size of the xbd block device, its
sector size and total number of sectors.
xbd%d: WARNING: cache flush not supported by backend The backend driver associated with
this xbd device does not support cache flushing operation. This can be problematic for file
system operations that require cache sync to avoid data loss or corruption.
xbdback(4), xenbus(4), dkctl(8)
The xbd driver first appeared in NetBSD 3.0.
The xbd driver was written by Manuel Bouyer <bouyer@NetBSD.org>.
BSD January 8, 2011 BSD
All times are GMT -4. The time now is 12:09 AM.