UK(4) BSD Kernel Interfaces Manual UK(4)NAME
uk -- SCSI user-level driver
uk* at scsibus? target ? lun ?
The uk driver provides support for a process to address devices on the SCSI bus for which there is no configured driver.
A SCSI adapter must also be separately configured into the system before this driver makes sense.
If a count is given, that number of uk devices will be configured into the NetBSD kernel.
The uk driver has no ioctls of its own but rather acts as a medium for the generic scsi(4) ioctls. These are described in <sys/scsiio.h>.
/dev/uk[0-255] unknown SCSI devices.
All scsi(4) debug ioctls work on uk devices.
SEE ALSO ioctl(2), cd(4), ch(4), scsi(4), sd(4), ss(4), st(4)HISTORY
The uk driver appeared in 386BSD 0.1.
BSD October 11, 1993 BSD
Check Out this Related Man Page
SES(4) BSD Kernel Interfaces Manual SES(4)NAME
ses -- SCSI Environmental Services driver
The ses driver provides support for all SCSI devices of the environmental services class that are attached to the system through a supported
SCSI Host Adapter, as well as emulated support for SAF-TE (SCSI Accessible Fault Tolerant Enclosures). The environmental services class gen-
erally are enclosure devices that provide environmental information such as number of power supplies (and state), temperature, device slots,
and so on.
A SCSI Host adapter must also be separately configured into the system before a SCSI Environmental Services device can be configured.
It is only necessary to explicitly configure one ses device; data structures are dynamically allocated as devices are found on the SCSI bus.
A separate option, SES_ENABLE_PASSTHROUGH, may be specified to allow the ses driver to perform functions on devices of other classes that
claim to also support ses functionality.
The following ioctl(2) calls apply to ses devices. They are defined in the header file <cam/scsi/scsi_ses.h> (q.v.).
SESIOC_GETNOBJ Used to find out how many ses objects are driven by this particular device instance.
SESIOC_GETOBJMAP Read, from the kernel, an array of SES objects which contains the object identifier, which subenclosure it is in, and the
ses type of the object.
SESIOC_GETENCSTAT Get the overall enclosure status.
SESIOC_SETENCSTAT Set the overall enclosure status.
SESIOC_GETOBJSTAT Get the status of a particular object.
SESIOC_SETOBJSTAT Set the status of a particular object.
SESIOC_GETTEXT Get the associated help text for an object (not yet implemented). ses devices often have descriptive text for an object
which can tell you things like location (e.g., "left power supply").
SESIOC_INIT Initialize the enclosure.
The files contained in <usr/share/examples/ses> show simple mechanisms for how to use these interfaces, as well as a very stupid simple moni-
/dev/sesN The Nth SES device.
When the kernel is configured with DEBUG enabled, the first open to an SES device will spit out overall enclosure parameters to the console.
The ses driver was written for the CAM SCSI subsystem by Matthew Jacob. This is a functional equivalent of a similar driver available in
Solaris, Release 7.
BSD January 29, 2000 BSD
I have a question.
/pci@1f,4000/scsi@3/disk is one of my device name.
The scsi@3 stands for SCSI id - 3. ( Is that Correct ?) . But the
disk alias points to /pci@1f,4000/scsi@3/disk@0,0 ( that is target 0 )
What is the significane of SCSI@3, when all devices are having... (6 Replies)
I have been attempting for the last few hours to change the root device to IDE from and SCSI adapter ... after modifying who knows how many files... (system still runs as long as the SCSI controller is present) ... as soon as I take it out, it gives me a panic, saying that rootdev cannot be... (3 Replies)
How do I mirror an external scsi vg to one hdisk san? The vg has multiple hdisks and the san hdisk has only one.
Is this possible or do I need to create the same hdisks as the scsi? What I meant is, if the scsi vg has 10 hdisk then I need to create also 10 hdisk of san with the same... (6 Replies)
i read the reply at this link
and i really surprised and i want to know if it must the mirrored HDD be on the secondary SCSI port and the operated HDD on Primary SCSI port?
thanks (3 Replies)
Linux / Kernel experts,
Please help. I'm getting errors with various return codes, similar to:
kernel: SCSI error : <0 0 5 165> return code = 0x8000002
I would like to know how / where to lookup the definition of the numbers between the angle brackets, and the return code itself.
I... (3 Replies)
we have sun T5240 server, we have taken ufsdump of this server remotely with scsi tapedrive, If we need to do ufsrestore means what we have to do, since T5240 has not having scsi port, any procedure is there?
Rajasekar (5 Replies)
I've done migration of my SCO 5.0.6 from SCSI to IDE hard disk and now I'm getting in X windows this message:
CONFIG: No Stp SCSI devices configured (unit 0 missing)
Howto configure to get this message away? (4 Replies)
I need only the last .ko files to be stripped from the whole result., ie libiscsi2.ko, scsi_transport_iscsi2.ko etc..
kernel/fs/nls/nls_utf8.ko... (4 Replies)
I am using the KGDB to debug my own network driver on linux. But I suspect if my KGDB work nomally. When I set a breakpoint at "do_one_initcall" function, the kernel function that will call my driver module, and continue to reach there, the "step" command of GDB cannot enter into my... (3 Replies)