THINKPAD(4) BSD Kernel Interfaces Manual THINKPAD(4)NAME
thinkpad -- IBM/Lenovo Thinkpad laptop features support
thinkpad* at acpi?
The thinkpad driver provides support for vendor specific features found in IBM and Lenovo brand laptops, such as function key handling,
hotkey handling, and temperature and fan monitoring.
SEE ALSO acpi(4), aps(4), pmf(9), sysmon_envsys(9)HISTORY
The thinkpad device driver appeared in NetBSD 5.0.
Jared D. McNeill <firstname.lastname@example.org>
BSD June 9, 2010 BSD
Check Out this Related Man Page
ACPIWMI(4) BSD Kernel Interfaces Manual ACPIWMI(4)NAME
acpiwmi -- Windows Management Instrumentation support for ACPI
acpiwmi* at acpi?
acpiwmibus* at acpiwmi?
wmidell* at acpiwmibus?
wmieeepc* at acpiwmibus?
wmihp* at acpiwmibus?
wmimsi* at acpiwmibus?
The acpiwmi device driver provides an ACPI interface for Windows Management Instrumentation (WMI). The ACPI WMI interface is typically used
to support vendor specific features found in various laptops.
The following WMI mappings are supported:
wmidell Dell laptops
wmieeepc Some models of Asus Eee PC
wmihp Hewlett-Packard laptops
wmimsi MSI laptops
The functionality varies from vendor to vendor. Typically the interface is used for function and hotkey handling, but additional features
may be present.
SEE ALSO acpi(4), acpidalb(4)
Microsoft Corporation, Windows Instrumentation: WMI and ACPI, http://www.microsoft.com/whdc/system/pnppwr/wmi/wmi-acpi.mspx, December 4,
The acpiwmi device driver appeared in NetBSD 6.0.
Jukka Ruohonen <email@example.com> wrote acpiwmi and most of the mappings.
While WMI should provide a certain degree of portability across laptop models from a particular vendor, there is no guarantee that the map-
pings are functional in all models.
The wmihp driver may conflict with hpqlb(4).
BSD February 16, 2011 BSD
I am using Slackware 7 on my IBM Thinkpad. I am unable to configure it to display a graphical environment. Typing startx usually generates a few errors. The system, however, does boot into the shell environment without any issues or problems. I have been able to setup Slackware 7 successfully... (2 Replies)
I have in my possession an IBM Thinkpad 390X. I havebeen using word and lately a function delaing with the Fn button have created problems. It acts as if Fn is depressed though it is not. When I depress Fn I can type normally, the keys it affects are J,K,L,:,U,I,O,P,M,<,>,? Does anyone know how to... (0 Replies)
i'm quite new to solaris and recently i've bought a ibm thinkpad...
now i intend to install a dual-boot system. in fact i've got it managed to install the end-user system
with dual-boot working. apart from following issue other devices got recognized...
this is what i've found out... (2 Replies)
I'm working on a for-fun project where I'm assembling a mass of various old computers, including a number of earlier UNIX workstations. They will be on display at a number of east coast conferences (HOPE, Shmoocon, etc).
I'm trying to find a Thinkpad 860, 850, 820 or one... (1 Reply)
Here's a conundrum. I use a ThinkPad (T30) which has a slot on the side for the hard drive. It is very easy to swap this with another hard drive which I keep as a backup. Now when I copy the Linux partition from my (in use) hard drive to the backup one (in my UltraBay slot) it takes only 30... (0 Replies)
Is it possible to install Ubuntu 11.04 or Ubuntu 11.10 in Lenovo Thinkpad E520-1143 Now it Powerd By windowd Xp Professional is it possible to install Ubuntu in it and supports all drivers for ma laptop such as VGA driver Sound,Wireless,Lan , fingerprint,camera pls reply r is it possible to... (0 Replies)
I use Solaris 10 on my desktop but would like to start using it on my laptop, which is a Thinkpad T400. I am moderately experienced in using Solaris but don't have much experience in installing it on anything other than my desktop. It seems I've managed to get it installed on the... (0 Replies)
I have a Thinkpad - T430, which is having the wireless card as "03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205".
This one i need to configure as wifi hotspot. which i believe need to configure hostapd.conf, this kind of configuration is new to me anybody done... (1 Reply)
My LENOVO ThinkPad T580 is crashing on Ubuntu 18.04. The crashes are seemingly happening at random. I tried running the following command as specified by this SO post:
sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04
However, that did not work the system... (10 Replies)
I run Devuan ASCII on my T400 laptop. I only use the trackpoint ("nipple mouse"). To me, the touchpad is just a nuisance.
I've discovered (by monitoring output of sudo cat /dev/input/event5) that the touchpad generates random input while the lid is closed. This causes applications that should... (5 Replies)