|Linux & Unix Commands - Search Man Pages
STI(4) BSD Kernel Interfaces Manual STI(4)
sti -- HP Standard Text Interface
sti* at mainbus0
sti* at phantomas?
sti* at pci?
wsdisplay* at sti?
The sti was created by HP to provide uniform frame-buffer access operations for their
9000/300 and 9000/700 series of workstations.
The following models are supported (though not all features or frame buffer depths may be
Model Bits Mem 3D Machines/Cards
EVRX 8 2 HP9000/425e
GRX 8g 2 SGC
CRX 8 2 SGC
Tomcat 8 2 SGC
Stinger 8 2 HP9000/75/74i
Artist 8 2 HP9000/712/75/74i
CRX-24 24 16 SGC
HCRX-8 8 2 GSC
HCRX-24 24 16 GSC
Visualize EG 16 2 HP B/C-class, GSC/PCI
Visualize FXE 24 24 y PCI 32/66
Visualize FX2 24 24 y PCI 64/66
Visualize FX4/FX6 24 32 y PCI 64/66
Implementation consists of a set of functions burnt in to the PROM on the card and providing
the following set of functions (see below for PROM revision history on functions supported
by particular PROM revision):
o Initialize graphics.
o State management.
o Print a character onto the screen using currently selected font.
o Copy a region of the frame-buffer to another location.
o Self testing.
o Exception handling.
o Frame-buffer configuration enquiry.
o Setting colour-map entry.
o DMA parameters.
o Flow control.
o User timing.
o Processing management.
o Miscellaneous utility functions.
There are two modes for accessing the PROM: ``byte'' and ``word'' mode. In ``byte'' mode
each 4-byte word contains only the low-ordered big-endian byte of data; i.e., to compose one
word of data 4 words should be read and low-ordered bytes of those should be shifted corre-
spondingly. In ``word'' mode each word contains all 4 bytes of valid data.
PROM revision history:
o OSF-extended self test (a.k.a fast).
o Restore display.
o Implement curr_mon function.
o Graphical boot screen.
o Implement ``block move''.
o Implement ``set colour-map entry''. sti Implement word mode.
o Support for multiple monitors.
o Support user_data sti space usage.
o Support for extra memory.
o Support for Windows NT (tm).
o Monitor frequency reference.
o Early console.
o Support added for: PCXL, GSC bus, ROM-less operation.
o Interrupt support.
o Report card's power usage.
o Birds of Prey.
o User interrupts.
o Multiple fonts.
o Monitor table descriptor strings.
o PCXL2 and PCXU monitor descriptors.
o HP-UX 10 support for Visualize FX
o dma_ctrl function added.
o flow_ctrl function added.
o user_timing function added.
o Addition changes for Visualize FX due to rearchitecture for performance.
o process_mgr function added.
PCXL2 and PCXU dual PCI EPROM map mode, implemented on Visualize EG.
Support for HP-UX non-implicit locking DMA, implemented on Visualize FXE.
sti_util function added (flashing under HP-UX and other sideband traffic).
Colour frame buffer support.
intro(4), phantomas(4), wsdisplay(4)
Standard Text Interface For Graphics Devices, Hewlett-Packard, Revision 8.13, March 1, 2000.
The sti driver was written by Michael Shalayeff <email@example.com> for HPPA port for
Currently, neither scroll back nor screen blanking functions are implemented.
BSD November 9, 2010 BSD
All times are GMT -4. The time now is 08:09 AM.