SPIF(4) BSD Kernel Interfaces Manual SPIF(4)NAME
spif -- SBus (spiffy) Serial/Parallel Interface
spif* at sbus? slot ? offset ? (sun4c/sun4m/sun4u)
stty* at spif? (sun4c/sun4m/sun4u)
sbpp* at spif? (sun4c/sun4m/sun4u)
The spif driver provides support for the Sun Serial/Parallel Interface card (Sun part number 501-1931), which is based on the Cirrus Logic
CD180 octal serial controller and the Cirrus Logic PPC2 parallel port controller.
The device minor numbers for this driver are encoded as follows:
| 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 |
| | | | | | | |
| | | | | +---+---+---> port number
| | | | |
| | | | +---------------> unused
| | | |
| | | +-------------------> dial-out (on tty ports)
| | |
| | +-----------------------> unused
+---+---------------------------> card number
Up to four cards are supported in the system.
Each of the serial ports has an 8 byte FIFO for receive and transmit as well as automatic hardware (RTS/CTS) flow control.
/dev/ttyS[0-7] Serial ports
/dev/bppS[0-3] Parallel ports
spif%d: ccr timeout A timeout occurred while writing to one of the CD180 registers.
stty%d-%d: ring overflow Incoming characters were discarded because the application in control of the device did not read the input fast
SEE ALSO intro(4), sbus(4), tty(4)HISTORY
The spif adapter was first supported in OpenBSD 2.5. The driver was ported to NetBSD 3.0.
The driver was written by Jason Wright <email@example.com>, and is heavily based on the magma(4) driver written by Iain Hibbert.
The parallel port is not supported yet.
Dial-out (cua) devices are not yet supported.
BSD February 4, 1999 BSD
Check Out this Related Man Page
ports(7) Miscellaneous Information Manual ports(7)NAME
ports, port_names - Device (tty and lp) names for serial and parallel ports
Default Serial Ports:
/dev/tty01 (not present on a single-port system)
AlphaStation and AlphaServer systems provide one or two 9-pin serial communication ports. These ports are usually labelled 1 (COMM1) and 2
(COMM2), but they may be identified by different icons. Using the appropriate serial cable and terminator, you can connect a serial
printer, external modem, or character-cell terminal to a serial port. Most AlphaStation and AlphaServer systems also provide one parallel
port, for use with a parallel printer.
When you add a device to your system, the installation documentation may instruct you to map the device pathname to the port. These
devices are located in the /dev directory.
For serial-line ports, the two default device pathnames are: This pathname always maps to 1, COMM1, the lowest port number, an icon for a
terminal console, or the only serial port (on a single-port system). This pathname always maps to 2, COMM2, the next numbered port, or (if
one serial port is labeled with an icon for a terminal console) the remaining serial port.
If your system hardware has been extended to include additional serial ports, the pathnames /dev/tty02, /dev/tty03, and so forth, may also
be available to you. However, most systems have only /dev/tty00 and /dev/tty01 as the device pathnames for serial ports.
The one parallel port on an AlphaStation or AlphaServer may be labeled with the word printer or a printer icon. On some systems, the paral-
lel port may not be labeled. The device pathname for the parallel port is /dev/lp0. Currently, Tru64 UNIX does not fully support parallel
printers, so fewer devices are connected to this port as compared to serial ports.
If you are connecting a terminal console to your system, it must be connected to the serial port mapped to /dev/tty00. For other serial
devices, it does not matter which of the serial ports you choose for the connection. For example, suppose you are setting up a system that
has two serial ports, labeled 1 and 2. You intend to use a serial-line terminal rather than a workstation monitor as the system console and
also want to connect a serial-line printer to the system. In this case, you must connect the terminal to the port labeled 1 (with the
device pathname /dev/tty00). Therefore, you must connect the printer to the remaining port labeled 2 (with the device pathname /dev/tty01).
If, for the same type of system, you intend to use a workstation monitor as the system console, it does not matter which serial port you
use for a serial-line printer or modem. In other words, you can connect the printer to either port 1 (with pathname /dev/tty00) or port 2
(with pathname /dev/tty01). When prompted to enter a /dev/tty** pathname by the lprsetup script or the Print configuration tool in the CDE
Application Manager, you would specify /dev/tty00 if you connected the printer to port 1 or /dev/tty01 if you connected the printer to port
See the System Administration manual for more information on setting up consoles (including remote consoles) and printers. See the
modem(7) reference page for more information on setting up modems.
Devices: ace(7), modem(7)
System Administration delim off