SONY(4) BSD Kernel Interfaces Manual SONY(4)NAME
sony -- Sony Miscellaneous Controller
SYNOPSIS
sony* at acpi?
DESCRIPTION
Some Sony notebook computers have a controller that handles various built-in devices. The sony driver provides support for accessing/modify-
ing the settings of some of these devices via the sysctl(8) interface.
The following sysctl(8) variables are available:
hw.sony0.brt [R/W] Controls current LCD brightness. Range [0-8].
hw.sony0.pbr [R/W] Controls power on LCD brightness. Range [0-8].
hw.sony0.cdp [R/W] Controls CD power.
hw.sony0.pid [R/O] Unknown
hw.sony0.ctr [R/W] Unknown
hw.sony0.pcr [R/W] Unknown
hw.sony0.cmi [R/W] Unknown
hw.sony0.ams [R/W] Audio control (mute when 0)
hw.sony0.hke [R/O] Indicates a Host Key Event. Bits are set when an event occurs and cleared when this value is read. The following table
describes the bit set for each button pressed:
0x1000 S1 button
0x0800 S2 button
0x0200 Fn + F10 (magnify)
0x0100 Mute button
0x0020 Fn + F12 (suspend to disk)
0x0010 Fn + F7 (LCD/external monitor)
0x0008 Fn + F6 (brighter backlight)
0x0004 Fn + F5 (darker backlight)
0x0002 Fn + F4 (volume up)
0x0001 Fn + F3 (volume down)
SEE ALSO acpi(4), spic(4)HISTORY
The sony driver appeared in NetBSD 4.0.
AUTHORS
Sami Kantoluoto for the original driver and manual information. Christos Zoulas for cleaning up the driver and this manual page.
BUGS
o The sony driver just parses integer values from the acpi(4) tree. It could be more intelligent and parse other controls.
o The sysctl(8) interface is not great. The names of the sysctl(8) tree are not self-explanatory.
o No validity checks are performed on the user input. Playing with random values and/or unknown controls can harm your machine.
o The name of the driver is too generic.
BSD December 23, 2007 BSD
Check Out this Related Man Page
ACPI_ASUS(4) BSD Kernel Interfaces Manual ACPI_ASUS(4)NAME
acpi_asus -- Asus Laptop Extras
SYNOPSIS
To compile this driver into the kernel, place the following line in your kernel configuration file:
device acpi_asus
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
acpi_asus_load="YES"
DESCRIPTION
The acpi_asus driver provides support for the extra ACPI-controlled gadgets, such as hotkeys and leds, found on recent Asus (and Medion) lap-
tops. It allows one to use the sysctl(8) interface to manipulate the brightness of the LCD panel and the display output state. Hotkey
events are passed to devd(8) for easy handling in userspace with the default configuration in /etc/devd/asus.conf.
Currently, the following Asus laptops are fully supported:
xxN
A1x
A2x
A3N
A4D
A6VM
D1x
J1x
L2B
L2D
L2E
L3C
L3D
L3H
L4E
L4R
L5x
L8x
M1A
M2E
M6N
M6R
S1x
S2x
V6V
W5A
Eee PC
Additionally, acpi_asus also supports the Asus-compatible ATK0100 interface found in Samsung P30/P35 laptops.
SYSCTL VARIABLES
The following sysctls are currently implemented:
hw.acpi.asus.lcd_brightness
Makes the LCD backlight brighter or dimmer (higher values are brighter).
hw.acpi.asus.lcd_backlight
Turns the LCD backlight on or off.
hw.acpi.asus.video_output
Sets the active display to use according to a bitwise OR of the following:
0 No display
1 LCD
2 CRT
4 TV-Out
Some models also support video switching via the generic acpi_video(4) driver. Most models do not, however.
Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
SEE ALSO acpi(4), acpi_asus_wmi(4), acpi_video(4), sysctl.conf(5), sysctl(8)
The acpi4asus Project, http://sourceforge.net/projects/acpi4asus/.
HISTORY
The acpi_asus driver first appeared in FreeBSD 5.3.
AUTHORS
The acpi_asus driver and this manual page were written by Philip Paeps <philip@FreeBSD.org>.
Inspiration came from the acpi4asus project started by Julien Lerouge which maintains a driver implementing this functionality in the Linux
kernel.
BSD February 8, 2010 BSD