SHB(4) BSD Kernel Interfaces Manual SHB(4)NAME
shb -- bus for SuperH on-chip peripheral devices
shb* at mainbus?
The shb driver provides a bus to which drivers for integrated peripheral devices found in various SuperH microprocessors attach.
adc analog/digital converter.
sci serial communication interface.
scif serial communication interface with FIFO.
wdog watchdog timer.
SEE ALSO adc(4), sci(4), scif(4), wdog(4)HISTORY
The shb driver first appeared in NetBSD 1.5.
BSD October 21, 2003 BSD
Check Out this Related Man Page
SPI(4) BSD Kernel Interfaces Manual SPI(4)NAME
spi -- introduction to machine-independent SPI bus support and drivers
spi* at mainbus?
Other attachments are machine-dependent and will depend on the bus topology of your system. See intro(4) for your system for more informa-
NetBSD includes a machine dependent SPI (Serial Peripheral Interface) bus subsystem, and several different machine-independent SPI device
Your system may support additional machine-dependent SPI devices. Consult your system's intro(4) for additional information.
SPI is a 4-wire synchronous full-duplex serial bus. Some systems provide support for Microwire, which is Philips' name for a strict subset
of SPI, with more rigidly defined signaling. Therefore, Microwire devices are also supported by the SPI framework.
Note that when referencing SPI devices in a config(1) file, the 'slave' must be provided, as SPI lacks any way to automatically probe
NetBSD includes the following machine-independent SPI drivers
m25p STMicroelectronics M25P family of NOR flash devices.
tm121temp Texas Instruments TMP121 temperature sensor.
SEE ALSO m25p(4), tm121temp(4)HISTORY
The machine-independent SPI framework was written by Garrett D'Amore for the Champaign-Urbana Community Wireless Network Project (CUWiN), and
appeared in NetBSD 4.0.
BSD October 9, 2006 BSD
I am new to this forum. I would really appreciate if some one from you expert team could answer my qns:
1) whats the difference between the below commands. what events occur in the background when I fire each of the three commands.
... (11 Replies)
I noticed some strange looking parameters on some processes on one of our servers, and after a little playing around we deduced that ksh seemed to be adding a (somewhat random) extra parameter when calling a script without a hashbang in it.
It looks like it's the partial name of the parent... (10 Replies)
Now that I'm caught-up on a number of forum tasks, I can turn my attention to the next-generation UserCP (and learn VueJS) for the site.
Today I created this (not yet functional) demo using Vue;
What do you think? (36 Replies)
Creating a Simple Linux Dashboard with Oracle Jet - Part 1 the Server Side PHP Code
Creating a simple Linux dashboard with Oracle Jet is easy and fun. It's simple to create a dashboard to monitor your Linux server using Oracle JET. The sky is the limit with indicators and gauges.
... (7 Replies)