|Linux & Unix Commands - Search Man Pages
SDTEMP(4) BSD Kernel Interfaces Manual SDTEMP(4)
sdtemp -- JEDEC JC-42.4 compatible memory module temperature sensors
sdtemp* at iic? addr 0x18
sdtemp* at iic? addr 0x19
sdtemp* at iic? addr 0x1a
sdtemp* at iic? addr 0x1b
sdtemp* at iic? addr 0x1c
sdtemp* at iic? addr 0x1d
sdtemp* at iic? addr 0x1e
sdtemp* at iic? addr 0x1f
The sdtemp driver provides support for the Microchip Technology MCP9805/98242 and other
chips that conform to JEDEC Standard 21-C section 4.7. Memory module temperature sensors
are optional on DDR2 and DDR3 SDRAM DIMMs. Sensors provided by this driver, including the
on-chip thresholds for the Alarm Window and Critical level, are accessed through the
The sdtemp supports temperature ranges from -256 to +255 degrees C.
Chips supported by the sdtemp driver include:
o Catalyst CAT34TS02 and CAT6095
o Analog Devices ADT7408
o Integrated Deviced Technology TSE2002B3 and TSE3000B3
o Maxim MAX6604
o Microchip Technology MCP9805, MCP9843, MCP98242, and MCP98243
o NXP Semiconductors SE97 and SE98
o STmicroelectronics STTS424 and STTS424E
The sdtemp device appeared in NetBSD 6.0.
Interrupt support is unimplemented.
BSD January 8, 2011 BSD
All times are GMT -4. The time now is 03:08 PM.