RCONS(4) BSD Kernel Interfaces Manual RCONS(4)NAME
rcons -- raster console access
pseudo-device rasterconsole N
The rcons driver provides support for machine-independent access to the raster console. Use of the rcons driver is deprecated in favour of
the wscons(4) machine-independent console driver.
The rcons driver provides simple raster and frame buffer routines. It's enough to implement a console terminal emulator on monochrome and
SEE ALSO wscons(4)BSD September 21, 2001 BSD
Check Out this Related Man Page
console(7D) Devices console(7D)NAME
console - STREAMS-based console interface
The file /dev/console refers to the system console device. /dev/console should be used for interactive purposes only. Use of /dev/console
for logging purposes is discouraged; syslog(3C) or msglog(7D) should be used instead.
The identity of this device depends on the EEPROM or NVRAM settings in effect at the most recent system reboot; by default, it is the
``workstation console'' device consisting of the workstation keyboard and frame buffer acting in concert to emulate an ASCII terminal (see
Regardless of the system configuration, the console device provides asynchronous serial driver semantics so that, in conjunction with the
STREAMS line discipline module ldterm(7M), it supports the termio(7I) terminal interface.
SEE ALSO syslog(3C), termios(3C), ldterm(7M), termio(7I), msglog(7D), wscons(7D)NOTES
In contrast to pre-SunOS 5.0 releases, it is no longer possible to redirect I/O intended for /dev/console to some other device. Instead,
redirection now applies to the workstation console device using a revised programming interface (see wscons(7D)). Since the system console
is normally configured to be the work station console, the overall effect is largely unchanged from previous releases.
See wscons(7D) for detailed descriptions of control sequence syntax, ANSI control functions, control character functions and escape
SunOS 5.10 23 Apr 1999 console(7D)
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)