PAD(4) BSD Kernel Interfaces Manual PAD(4)NAME
pad -- Pseudo audio device driver
SYNOPSIS
pseudo-device pad
audio* at audiobus?
DESCRIPTION
pad is a pseudo-device driver which provides support for feeding back PCM data from a consumer of the audio(4) API to userland.
FILES
The pad pseudo-device driver receives data from /dev/soundN and feeds the raw PCM output to /dev/padN.
/dev/soundN
/dev/padN
EXAMPLES
The following example streams an MP3 to an Apple AirTunes compatible device:
$ rtunes - < /dev/pad0 &
$ mpg123 -a /dev/sound1 mozart.mp3
SEE ALSO audio(4)HISTORY
The pad driver appeared in NetBSD 5.0.
AUTHORS
Jared D. McNeill <jmcneill@invisible.ca>
BSD November 11, 2007 BSD
Check Out this Related Man Page
AUDIOCTL(1) BSD General Commands Manual AUDIOCTL(1)NAME
audioctl -- control audio device
SYNOPSIS
audioctl [-d device] [-n] -a
audioctl [-d device] [-n] name ...
audioctl [-d device] [-n] -w name=value ...
DESCRIPTION
The audioctl command displays or sets various audio system driver variables. If a list of variables is present on the command line, then
audioctl prints the current value of those variables for the specified device. If the -a flag is specified, all variables for the device are
printed. If the -w flag is specified audioctl attempts to set the specified variables to the given values.
The -d flag can be used to give an alternative audio control device, the default is /dev/audioctl0.
The -n flag suppresses printing of the variable name.
ENVIRONMENT
AUDIOCTLDEVICE the audio control device to use.
FILES
/dev/audio0 audio I/O device (resets on open)
/dev/audioctl0 audio control device
/dev/sound0 audio I/O device (does not reset on open)
EXAMPLES
To set the playing sampling rate to 11025, you can use
audioctl -w play.sample_rate=11025
To set all of the play parameters for CD-quality audio, you can use
audioctl -w play=44100,2,16,slinear_le
Note that many of the variables that can be inspected and changed with audioctl are reset when /dev/audio0 is opened. This can be circum-
vented by using /dev/sound0 instead.
COMPATIBILITY
The old -f flag is still supported. This support will be removed eventually.
SEE ALSO audioplay(1), audiorecord(1), mixerctl(1), audio(4), sysctl(8)HISTORY
The audioctl command first appeared in NetBSD 1.3.
BSD January 27, 2002 BSD
Hi all,
I have file with numeric values. I need to pad each value with leading zeros such that total lenght of each value is 16.
Example:
cat tmp.txt
502455
50255
5026
5027
5028
Output
0000000000502455
0000000000050255
0000000000005026
0000000000005027
0000000000005028
Any... (12 Replies)
We have Sun OS running on spark :
SunOS ciniwnpr67 5.10 Generic_118833-24 sun4u sparc SUNW,Sun-Fire-V440
Having Physical RAM :
Sol10box # prtconf | grep Mem
Memory size: 8192 Megabytes
My Top Output is :
130 processes: 129 sleeping, 1 on cpu
CPU states: 98.8% idle, 0.2% user, 1.0%... (39 Replies)
We have Sun OS running on spark :
SunOS ciniwnpr67 5.10 Generic_118833-24 sun4u sparc SUNW,Sun-Fire-V440
Having Physical RAM :
Sol10box # prtconf | grep Mem
Memory size: 8192 Megabytes
My Top Output is :
130 processes: 129 sleeping, 1 on cpu
CPU states: 98.8% idle, 0.2% user, 1.0%... (27 Replies)
Hi Friends,
I would like to left pad with "0's" on first column say (width six)
I have a large file with the format:
FILE:
1: ALFRED 84378 NY
8385: JAMES 88385 FL
323: SMITH 00850 TX
My output needs to be like:
000001: ALFRED 84378 NY
008385: JAMES 88385 FL
000323: SMITH... (10 Replies)
I am new to using UNIX and after uploading a new script to UNIX from Windows using FTP, the script doesn't always work. It seems this depends on the text editor I use and the transfer type. I understand all scripts should be transferred using ASCII, but can you advise which is the best text editor... (12 Replies)
I was wondering someone might be able to push me in the right direction, I am writing a script to modify fixed-width spool files, As you can see below the original spool file broke a single line into two for printability sake.
I have had been able do the joins using sed, the thing I am... (10 Replies)
Hey!
I used to dive a lot and got my PADI Open Water Diver certification many years ago. Now, I'm thinking about getting back into diving and taking a PADI Advanced Open Water diver course after a few fun refresher dives.
Any divers on the site? (11 Replies)
Hello,
I'm facing severe structure padding issues when my Solaris C/C++ application that runs on Sparc communicates with the same C/C++ application that runs on Intel. I know that Sparc and Intel use different padding patterns. So when it comes to reading the exchanged structure data, both... (11 Replies)
I have number/strings like below
input =23412133
output = 234121330000 (depends on the number give at runtime)
i need to padd zeros based on runtime input . i tried below
printf ' %d%04d\n', "23412133";
But the precision 4 is static here how can i pass this as runtime input.
i am... (11 Replies)
I need to read in the string from input file and reform it by cut each segment and check the last segement lenght. If the last segment length is not as expected (see below segment file or table. It is predefined), then pad enough space.
Old string
FU22222222CA6666666666AKxvbFMddreeadBP999... (11 Replies)
Hello, here is the outout of the command below.. Can someone please tell me how to get the output as below
output needed:
18914,30716,17051,4139,14155...
( no comma for the last value)
ps -e -o pcpu,pid,user,tty,args | sort -n -k 1 -r | head | awk '{print $2}'
18914
30716
17051
4139... (10 Replies)
Is possible to print padded string in printf?
Example
echo 1 | awk '{printf("%03d\n", $1)}'
001I want
S1
S11
S2
S21to be padded as:
S01
S11
S02
S21Thanks! (26 Replies)