ONEWIRE(4) BSD Kernel Interfaces Manual ONEWIRE(4)NAME
onewire -- 1-Wire bus
SYNOPSIS
onewire* at gpioow?
option ONEWIREVERBOSE
DESCRIPTION
1-Wire bus was originally developed by Dallas Semiconductor for connecting integrated circuits. It is commonly used for connecting devices
such as electronic keys, EEPROMs, temperature sensors, real-time clocks, security chips, etc.
The onewire driver provides a uniform programming interface layer between 1-Wire master controllers and various 1-Wire slave devices. Each
1-Wire master controller attaches a onewire framework; several slave devices can then be attached to the onewire bus.
The driver supports plugging and unplugging slave devices on the fly.
SUPPORTED MASTERS gpioow(4) 1-Wire bus bit-banging through GPIO pin
SUPPORTED SLAVES owtemp(4) temperature family type device
SEE ALSO intro(4)HISTORY
The onewire driver first appeared in OpenBSD 4.0 and NetBSD 4.0.
AUTHORS
The onewire driver was written by Alexander Yurchenko <grange@openbsd.org> and ported to NetBSD by Jeff Rizzo <riz@NetBSD.org>.
BSD April 4, 2006 BSD
Check Out this Related Man Page
IEEE1394IF(4) BSD Kernel Interfaces Manual IEEE1394IF(4)NAME
ieee1394if -- IEEE1394 High-performance Serial Bus
SYNOPSIS
ieee1394if* at fwohci?
DESCRIPTION
NetBSD provides machine-independent bus support and raw drivers for IEEE1394 interfaces.
The ieee1394if driver consists of two layers: the controller and the bus layer. The controller attaches to a physical bus (like pci(4)).
The ieee1394if bus attaches to the controller. Additional drivers can be attached to the bus.
Up to 63 devices, including the host itself, can be attached to a IEEE1394 bus. The root node is dynamically assigned with a PHY device
function. Also, the other IEEE1394 bus specific parameters, e.g., node ID, cycle master, isochronous resource manager and bus manager, are
dynamically assigned, after bus reset is initiated. On the ieee1394if bus, every device is identified by an EUI 64 address.
FILES
/dev/fw0.0
/dev/fwmem0.0
SEE ALSO fwip(4), fwohci(4), pci(4), sbp(4), fwctl(8), sysctl(8)HISTORY
The ieee1394if driver first appeared in FreeBSD 5.0, as firewire. It was added to NetBSD 4.0 under its present name.
AUTHORS
The ieee1394if driver was written by Katsushi Kobayashi and Hidetoshi Shimokawa for the FreeBSD project. It was added to NetBSD 4.0 by
KIYOHARA Takashi.
BUGS
See fwohci(4) for security notes.
BSD June 18, 2005 BSD
Hi,
I am getting a bus error when i run the following code.
#include <stdio.h>
#include <sys/types.h>
#include <sys/ipc.h>
#include <sys/sem.h>
#include <errno.h>
main()
{
int semid,retval;
semid=semget(0x20,1,IPC_CREAT|0666);
retval= semctl(semid,0,GETVAL,0);
printf("The... (1 Reply)
Hello
I'm making script for Dallas temperature sensors (DS1820).
When a sensor is connected, it shows up as a directory in /sys/bus/w1/devices
in format 10-xxxxxxx. Inside the directory is a file called w1_slave which holds the temperature in format t=xxxxx.
Each sensor has unique... (2 Replies)