|Linux & Unix Commands - Search Man Pages
ISV(4) BSD Kernel Interfaces Manual ISV(4)
isv -- IDEC Supervision/16 image capture board
isv0 at isa? port 0x2f0
isv0 at isa? port 0x2e0
isv0 at isa? port 0x3f0
isv0 at isa? port 0x3e0
isv is a driver for the IDEC Supervision/16, an image capture board that plugs into a 16-bit
ISA bus. The IDEC Supervision/16 digitizes an NTSC television signal, storing a 512 x
480-pixel, 8-bit grayscale image in its 256kB dynamic RAM array every 1/30th of a second.
The host reads frames from the DRAM using 122881 16-bit I/O reads. Reading frames from the
Supervision/16 is quite slow: after the host reads a 16-bit word from the DRAM, the Supervi-
sion/16 state machine takes approximately 0.5 microseconds to get ready for the next read.
Theoretically, a frame rate of approximately 10 frames per second is possible. isv achieves
a frame rate of approximately 6 frames per second.
Programming the Supervision/16 Image Capture Board, IDEC, circa 1991.
The isv device first appeared in NetBSD 5.0.
The isv driver was written by David Young <dyoung@NetBSD.org>.
Synchronizing with the hardware and reading frames from it is very CPU-intensive.
isv will not detect the capture board if it is not attached to an active video source. To
force NetBSD to detect the capture board at any time, re-scan the ISA bus using, e.g.,
drvctl -r isa0.
BSD April 1, 2008 BSD
All times are GMT -4. The time now is 05:04 PM.