ISDNBCHAN(4) BSD Kernel Interfaces Manual ISDNBCHAN(4)NAME
isdnbchan -- ISDN Raw B-Channel access driver
pseudo-device isdnbchan count
The isdnbchan driver provides an interface to the raw untranslated B-channel.
SEE ALSO isdnd.rc(5), isdnd(8)AUTHORS
The isdnbchan device driver and this man page were written by Hellmuth Michaelis <firstname.lastname@example.org>.
BSD February 3, 1998 BSD
Check Out this Related Man Page
ISDN(4) BSD Kernel Interfaces Manual ISDN(4)NAME
isdn -- ISDN kernel to userland master device
The isdn device driver is used by the isdnd(8) daemon to exchange messages with the ISDN kernel part for the purpose of call establishment,
control and disconnection and to access various control and status information.
The messages and message parameters are documented in the include file /usr/include/netisdn/i4b_ioctl.h.
The available ioctl's are:
Request a unique Call Description IDentifier (cdid) which identifies uniquely a single interaction of the local D channel with
Actively request a call setup to a remote ISDN subscriber.
Respond to an incoming call, either accept, reject or ignore it.
Actively terminate a connection.
Request information about an installed ISDN controller card.
Give information about call setup to driver who requested dialing out.
Update the kernels timeout value(s) in case of dynamically calculated shorthold mode timing changes.
Inform the kernel userland drivers about interface soft up/down status changes.
Download firmware to active card(s).
Return diagnostic information from active cards.
Status and event messages available from the kernel are:
An incoming call from a remote ISDN user is indicated.
After an incoming call has been accepted locally or an outgoing call has been accepted by a remote, the exchange signaled an
active connection and the corresponding B-channel is switched through.
A call was terminated.
A userland interface driver requests the daemon to dial out (typically a network interface when a packet arrives in its send
A call was terminated by the isdn4bsd kernel driver because a B-channel idle timeout occurred.
Accounting information from a network driver.
Charging information from the kernel.
SEE ALSO isdnd(8)AUTHORS
The isdn device driver and this man page were written by Hellmuth Michaelis <email@example.com>.
BSD February 3, 1998 BSD
I have seen some misinformation regarding Unix file permissions. I will try to set the record straight. Take a look at this example of some output from ls:
$ ls -ld /usr/bin /usr/bin/cat
drwxrwxr-x 3 root bin 8704 Sep 23 2004 /usr/bin
-r-xr-xr-x 1 bin bin ... (6 Replies)
I have a file which looks roughly like this:
and would like to sort it numerically on the first field. I tried:
sort -nr --key=1 ....
The output I get is:
9964 ... (3 Replies)
Suppose I have a main() function with only one malloc statement allocating say some 1 gb memory. Also say my system has 1 gb of ram.
The program above exits without freeing the memory.
In this case will the 1 gb of heap memory be returned... (9 Replies)
I'm trying to install a PGX32 video card on my Sparc 10 Ultra running Solaris 10.
I've got the Oracle installation guide for it and I got as far as:
"4. Insert the CD-ROM labeled “GFX OpenWindows for Solaris 2” into the drive."
I don't have a CD-ROM by that name and a web search for that... (21 Replies)
I'm writing a short script to check if a continuous port is running on a server.
I'm using "ps -ef | grep -v grep | grep processName" and I was wondering if it was better/more reliable to just check the
return code from the command or if its better to pipe to... (12 Replies)
I installed NetBSD 6.1.2 amd64 and can't find the apm utility. Is it not in the base system?
Is it necessary to recompile the default amd64 kernel to use apm?
Or is there a new method for power management and suspend/resume? (2 Replies)
I am learning shell scripting for the first time. I use AT&T Korn Shell, Version AJM 93u+ 2012-08-01, compiled from source on NetBSD.
So far I have managed to set up what I think is a useful and pleasing shell prompt, which can be seen in the image attached to this post.
The prompt is... (2 Replies)
Hey gang, I have a list of times I need to sum up. This list can vary from a few to a few thousand entries. Now I had found a closed reference to adding time titled "add up time with xx:yy format in bash how?" In it, the example works great for that formatted list of times... This is the reply code... (5 Replies)
Usually when I on the evening go to bed I take some interesting book with me. I read it for a while to get me down to sleep. Probably most people seek information from the Nett by googleing but I am so oldfashioned I prefer a real book ;)
But what a book. The one I found and ordered is BSD Unix®... (0 Replies)
On the late 1960s I got short hands on experience with a russian "small" computer. It vas a copy of DEC's VAX ... and running some version of BSD-Unix. After that I worked in a university following the development of computing. After retire I started collecting old pc's and installing... (13 Replies)