Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

irframe(4) [netbsd man page]

IRFRAME(4)						   BSD Kernel Interfaces Manual 						IRFRAME(4)

NAME
irframe -- IrDA frame level driver SYNOPSIS
irframe* at oboe? irframe* at uirda? irframe* at ustir? pseudo-device irframetty #include <dev/irdaio.h> DESCRIPTION
The irframe driver provides support for IrDA frame level transmission. It does not contain the IrDA protocol stack per se, but the stack can be built on top of the irframe driver. Access to frames is via the read(2) and write(2) system calls. Each write constitutes one frame, and each read yields one frame. The poll(2) system call can be used to check for availability of frames. There are also a number of ioctl(2) calls to manipulate the device: IRDA_RESET_PARAMS Reset the parameters set by IRDA_SET_PARAMS. IRDA_SET_PARAMS (struct irda_params) Set the speed, extra beginning of frame bytes, and maximum frame size. IRDA_GET_SPEEDMASK (int) Get the set of allowable speeds. IRDA_GET_TURNAROUNDMASK (int) Get the set of allowable turn around times. SEE ALSO
cir(4), irframetty(4), oboe(4), uirda(4), ustir(4) comms/birda package HISTORY
The irframe driver appeared in NetBSD 1.6. BSD
December 2, 2001 BSD

Check Out this Related Man Page

TAP(4)							   BSD Kernel Interfaces Manual 						    TAP(4)

NAME
tap -- virtual Ethernet device SYNOPSIS
pseudo-device tap DESCRIPTION
The tap driver allows the creation and use of virtual Ethernet devices. Those interfaces appear just as any real Ethernet NIC to the kernel, but can also be accessed by userland through a character device node in order to read frames being sent by the system or to inject frames. In that respect it is very similar to what tun(4) provides, but the added Ethernet layer allows easy integration with machine emulators or virtual Ethernet networks through the use of bridge(4) with tunneling. INTERFACE CREATION Interfaces may be created in two different ways: using the ifconfig(8) create command with a specified device number, or its ioctl(2) equiva- lent, SIOCIFCREATE, or using the special cloning device /dev/tap. The former works the same as any other cloning network interface: the administrator can create and destroy interfaces at any time, notably at boot time. This is the easiest way of combining tap and bridge(4). Later, userland will actually access the interfaces through the specific device nodes /dev/tapN. The latter is aimed at applications that need a virtual Ethernet device for the duration of their execution. A new interface is created at the opening of /dev/tap, and is later destroyed when the last process using the file descriptor closes it. CHARACTER DEVICES Whether the tap devices are accessed through the special cloning device /dev/tap or through the specific devices /dev/tapN, the possible actions to control the matching interface are the same. When using /dev/tap though, as the interface is created on-the-fly, its name is not known immediately by the application. Therefore the TAPGIFNAME ioctl is provided. It should be the first action an application using the special cloning device will do. It takes a pointer to a struct ifreq as an argument. Ethernet frames sent out by the kernel on a tap interface can be obtained by the controlling application with read(2). It can also inject frames in the kernel with write(2). There is absolutely no validation of the content of the injected frame, it can be any data, of any length. One call of write(2) will inject a single frame in the kernel, as one call of read(2) will retrieve a single frame from the queue, to the extent of the provided buffer. If the buffer is not large enough, the frame will be truncated. tap character devices support the FIONREAD ioctl which returns the size of the next available frame, or 0 if there is no available frame in the queue. They also support non-blocking I/O through the FIONBIO ioctl. In that mode, EWOULDBLOCK is returned by read(2) when no data is available. Asynchronous I/O is supported through the FIOASYNC, FIOSETOWN, and FIOGETOWN ioctls. The first will enable SIGIO generation, while the two other configure the process group that will receive the signal when data is ready. Synchronisation may also be achieved through the use of select(2), poll(2), or kevent(2). ETHERNET ADDRESS When a tap device is created, it is assigned an Ethernet address of the form f2:0b:a4:xx:xx:xx. This address can later be changed using ifconfig(8) to add an active link layer address, or directly via the SIOCALIFADDR ioctl on a PF_LINK socket, as it is not available on the ioctl handler of the character device interface. FILES
/dev/tap cloning device /dev/tap[0-9]* individual character device nodes SEE ALSO
bridge(4), etherip(4), tun(4), ifconfig(8) HISTORY
The tap driver first appeared in NetBSD 3.0. BSD
March 10, 2009 BSD
Man Page